summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Brenton Earl2015-12-04 19:05:39 +0100
committer Willy Sudiarto Raharjo2015-12-04 19:05:39 +0100
commite754ebb72ebe4ea58ee1b248304285a7ac8e0c21 (patch)
treef9581d2bcec798ef6b4c836dbdac7cb5bc39f089
parent703a54563f135ba9ac326c3267f91541ebe3a4f7 (diff)
downloadslackbuilds-e754ebb72ebe4ea58ee1b248304285a7ac8e0c21.tar.gz
python/pyperclip: Added (Python copy and paste clipboard functions).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pyperclip/README16
-rw-r--r--python/pyperclip/pyperclip-1.5-doc.pdfbin0 -> 67983 bytes
-rw-r--r--python/pyperclip/pyperclip.SlackBuild88
-rw-r--r--python/pyperclip/pyperclip.info10
-rw-r--r--python/pyperclip/slack-desc19
5 files changed, 133 insertions, 0 deletions
diff --git a/python/pyperclip/README b/python/pyperclip/README
new file mode 100644
index 0000000000..f24b18ae6a
--- /dev/null
+++ b/python/pyperclip/README
@@ -0,0 +1,16 @@
+Pyperclip is a cross-platform Python module for copy and paste clipboard
+functions. It works with Python 2 and 3. It currently only handles
+plaintext.
+
+Example Usage:
+
+>>> import pyperclip
+>>> pyperclip.copy('The text to be copied to the clipboard.')
+>>> pyperclip.paste()
+'The text to be copied to the clipboard.'
+
+PDF documentation included in /usr/doc/pyperclip-$VERSION
+
+Optional Dependencies:
+- xclip
+- xsel
diff --git a/python/pyperclip/pyperclip-1.5-doc.pdf b/python/pyperclip/pyperclip-1.5-doc.pdf
new file mode 100644
index 0000000000..99f743118e
--- /dev/null
+++ b/python/pyperclip/pyperclip-1.5-doc.pdf
Binary files differ
diff --git a/python/pyperclip/pyperclip.SlackBuild b/python/pyperclip/pyperclip.SlackBuild
new file mode 100644
index 0000000000..8ea8c04cbf
--- /dev/null
+++ b/python/pyperclip/pyperclip.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for pyperclip
+
+# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Maintainer Notes:
+# PDF Documentation downloaded from pyperclip.readthedocs.org 12/1/2015
+
+PRGNAM=pyperclip
+VERSION=${VERSION:-1.5.24}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp $CWD/pyperclip-1.5-doc.pdf PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyperclip/pyperclip.info b/python/pyperclip/pyperclip.info
new file mode 100644
index 0000000000..705d01ca8f
--- /dev/null
+++ b/python/pyperclip/pyperclip.info
@@ -0,0 +1,10 @@
+PRGNAM="pyperclip"
+VERSION="1.5.24"
+HOMEPAGE="https://github.com/asweigart/pyperclip"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pyperclip/pyperclip-1.5.24.zip"
+MD5SUM="4540f4178cc141dd4eb30d1b60f7f1ea"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Brenton Earl"
+EMAIL="brent@exitstatusone.com"
diff --git a/python/pyperclip/slack-desc b/python/pyperclip/slack-desc
new file mode 100644
index 0000000000..67f2cd5e6c
--- /dev/null
+++ b/python/pyperclip/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyperclip: pyperclip (Python copy and paste clipboard functions)
+pyperclip:
+pyperclip: Pyperclip is a cross-platform Python module for copy and paste
+pyperclip: clipboard functions. It works with Python 2 and 3.
+pyperclip:
+pyperclip: Home page: https://github.com/asweigart/pyperclip
+pyperclip:
+pyperclip:
+pyperclip:
+pyperclip:
+pyperclip: