summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author T3slider2015-12-02 20:10:36 +0100
committer Willy Sudiarto Raharjo2015-12-02 20:10:36 +0100
commitdfd57b9de43829e34f6b9feaf2bd50b863fca1f3 (patch)
treef9d27978746efef77488cdd4646719d2e08588d0
parent90a57a3bc71037a4e203f09afc70096d34395028 (diff)
downloadslackbuilds-dfd57b9de43829e34f6b9feaf2bd50b863fca1f3.tar.gz
network/ii: Added (minimalist IRC client).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/ii/README5
-rw-r--r--network/ii/ii.SlackBuild89
-rw-r--r--network/ii/ii.info10
-rw-r--r--network/ii/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/network/ii/README b/network/ii/README
new file mode 100644
index 0000000000..defeb9ef8e
--- /dev/null
+++ b/network/ii/README
@@ -0,0 +1,5 @@
+Irc it is a minimalist FIFO and filesystem-based IRC client. It creates
+an irc directory tree with server, channel and nick name directories. In
+every directory a FIFO in file and a normal out file is created. The in
+files are used to communicate with servers and the out files contain
+server messages. This allows IRC communication from the command line.
diff --git a/network/ii/ii.SlackBuild b/network/ii/ii.SlackBuild
new file mode 100644
index 0000000000..e508856f60
--- /dev/null
+++ b/network/ii/ii.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for ii
+
+# Copyright 2015 T3slider
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ii
+VERSION=${VERSION:-1.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e "s/-O.\>/$SLKCFLAGS/" -e "s/\<lib\>/$LIBDIRSUFFIX/" config.mk
+
+make PREFIX=/usr MANDIR=/usr/man DOCDIR=/usr/doc/$PRGNAM-$VERSION DESTDIR=$PKG install
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/ii/ii.info b/network/ii/ii.info
new file mode 100644
index 0000000000..010ec5edf7
--- /dev/null
+++ b/network/ii/ii.info
@@ -0,0 +1,10 @@
+PRGNAM="ii"
+VERSION="1.7"
+HOMEPAGE="http://tools.suckless.org/ii/"
+DOWNLOAD="http://dl.suckless.org/tools/ii-1.7.tar.gz"
+MD5SUM="6191008ca09770873d84f40270493d0e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="T3slider"
+EMAIL="t3slider@gmail.com"
diff --git a/network/ii/slack-desc b/network/ii/slack-desc
new file mode 100644
index 0000000000..67a8aa2902
--- /dev/null
+++ b/network/ii/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ii: Irc it (minimalist FIFO and filesystem-based IRC client)
+ii:
+ii: Irc it creates an irc directory tree with server, channel and nick
+ii: name directories. In every directory a FIFO in file and a normal out
+ii: file is created. The in files are used to communicate with servers
+ii: and the out files contain server messages. This allows IRC
+ii: communication from the command line.
+ii:
+ii: http://tools.suckless.org/ii/
+ii:
+ii: