summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2015-07-02 07:58:24 +0200
committer Willy Sudiarto Raharjo2015-07-04 05:38:14 +0200
commitef100fc9277d6395f1a1fdca496d8d86abeae5f6 (patch)
tree0483f7d4e9041c5314e85df2bbf960fe4cf49780
parent29e42556dcffd5814fb1f2bbada33352df3d6165 (diff)
downloadslackbuilds-ef100fc9277d6395f1a1fdca496d8d86abeae5f6.tar.gz
system/ttyrec: Added (tty recorder).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/ttyrec/README4
-rw-r--r--system/ttyrec/slack-desc19
-rw-r--r--system/ttyrec/ttyrec-1.0.8.RHEL5.patch33
-rw-r--r--system/ttyrec/ttyrec.SlackBuild98
-rw-r--r--system/ttyrec/ttyrec.info10
5 files changed, 164 insertions, 0 deletions
diff --git a/system/ttyrec/README b/system/ttyrec/README
new file mode 100644
index 0000000000..bb8b64513f
--- /dev/null
+++ b/system/ttyrec/README
@@ -0,0 +1,4 @@
+ttyrec is a tty recorder. Recorded data can be played back with
+the included ttyplay command. ttyrec is just a derivative of script
+command for recording timing information with microsecond accuracy as
+well. It can record emacs -nw, vi, lynx, or any programs running on tty.
diff --git a/system/ttyrec/slack-desc b/system/ttyrec/slack-desc
new file mode 100644
index 0000000000..956ffe270f
--- /dev/null
+++ b/system/ttyrec/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ttyrec: ttyrec (a tty recorder)
+ttyrec:
+ttyrec: ttyrec is a tty recorder. Recorded data can be played back with the
+ttyrec: included ttyplay command. ttyrec is just a derivative of script
+ttyrec: command for recording timing information with microsecond accuracy
+ttyrec: as well. It can record emacs -nw, vi, lynx, or any programs running
+ttyrec: on tty.
+ttyrec:
+ttyrec: Homepage: http://0xcc.net/ttyrec/index.html.en
+ttyrec:
+ttyrec:
diff --git a/system/ttyrec/ttyrec-1.0.8.RHEL5.patch b/system/ttyrec/ttyrec-1.0.8.RHEL5.patch
new file mode 100644
index 0000000000..900b017cb9
--- /dev/null
+++ b/system/ttyrec/ttyrec-1.0.8.RHEL5.patch
@@ -0,0 +1,33 @@
+diff -rupN original/Makefile new/Makefile
+--- original/Makefile 2006-06-11 10:52:50.000000000 -0500
++++ new/Makefile 2012-04-23 18:34:05.000000000 -0500
+@@ -1,5 +1,5 @@
+ CC = gcc
+-CFLAGS = -O2
++CFLAGS = -O2 -DHAVE_openpty
+ VERSION = 1.0.8
+
+ TARGET = ttyrec ttyplay ttytime
+@@ -10,7 +10,7 @@ DIST = ttyrec.c ttyplay.c ttyrec.h io.c
+ all: $(TARGET)
+
+ ttyrec: ttyrec.o io.o
+- $(CC) $(CFLAGS) -o ttyrec ttyrec.o io.o
++ $(CC) $(CFLAGS) -o ttyrec ttyrec.o io.o -lutil
+
+ ttyplay: ttyplay.o io.o
+ $(CC) $(CFLAGS) -o ttyplay ttyplay.o io.o
+diff -rupN original/ttyrec.c new/ttyrec.c
+--- original/ttyrec.c 2006-06-11 10:52:50.000000000 -0500
++++ new/ttyrec.c 2012-04-23 18:26:41.000000000 -0500
+@@ -71,7 +71,9 @@
+ #define _(FOO) FOO
+
+ #ifdef HAVE_openpty
+-#include <libutil.h>
++/* #include <libutil.h> */
++#include <pty.h> /* for openpty and forkpty */
++#include <utmp.h> /* for login_tty */
+ #endif
+
+ #if defined(SVR4) && !defined(CDEL)
diff --git a/system/ttyrec/ttyrec.SlackBuild b/system/ttyrec/ttyrec.SlackBuild
new file mode 100644
index 0000000000..f5bad042b7
--- /dev/null
+++ b/system/ttyrec/ttyrec.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for ttyrec
+
+# Copyright 2015 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ttyrec
+VERSION=${VERSION:-1.0.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fixed: "Out of pty's Terminated"
+patch -p1 < $CWD/ttyrec-1.0.8.RHEL5.patch
+
+make
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/bin $PKG/usr/man/man1
+BINS="rec play time"
+for exe in $BINS; do
+ # Install executables
+ install -D -m0755 tty$exe $PKG/usr/bin/tty$exe
+ # Install man pages
+ gzip -9 tty$exe.1
+ install -D -m0644 tty$exe.1.gz $PKG/usr/man/man1/tty$exe.1.gz
+done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/ttyrec/ttyrec.info b/system/ttyrec/ttyrec.info
new file mode 100644
index 0000000000..9a71801cc4
--- /dev/null
+++ b/system/ttyrec/ttyrec.info
@@ -0,0 +1,10 @@
+PRGNAM="ttyrec"
+VERSION="1.0.8"
+HOMEPAGE="http://0xcc.net/ttyrec/index.html.en"
+DOWNLOAD="http://0xcc.net/ttyrec/ttyrec-1.0.8.tar.gz"
+MD5SUM="bdd26ee6f0ff0d96699e66f9a6ba49ca"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"