summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2015-04-11 06:38:00 +0200
committer Willy Sudiarto Raharjo2015-04-12 05:06:48 +0200
commit371776a9a65172e8053f5a9831993e1737a5a4d3 (patch)
tree51e71ce94eed1ad5469622a9f6f0721e0453749d
parente5c4592d4b167af57a9fc36b1e88a68c9a1be695 (diff)
downloadslackbuilds-371776a9a65172e8053f5a9831993e1737a5a4d3.tar.gz
python/pysed: Updated for version 0.6.2.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/pysed/README4
-rw-r--r--python/pysed/pysed.SlackBuild12
-rw-r--r--python/pysed/pysed.info6
-rw-r--r--python/pysed/slack-desc2
4 files changed, 16 insertions, 8 deletions
diff --git a/python/pysed/README b/python/pysed/README
index 82209f7f68..ca361a2103 100644
--- a/python/pysed/README
+++ b/python/pysed/README
@@ -1,5 +1,5 @@
Pysed is a Python stream editor, is used to perform basic
text transformations from a file. It reads text, line by
line, from a file and replace, insert or print all text or
-specific area. One of the elements of distinction is the
-use of colors.
+specific area. Actually pysed is a passage of Python module
+‘re’ in terminal.
diff --git a/python/pysed/pysed.SlackBuild b/python/pysed/pysed.SlackBuild
index d578525e60..2cfbeb4a2d 100644
--- a/python/pysed/pysed.SlackBuild
+++ b/python/pysed/pysed.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pysed
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pysed
-VERSION=${VERSION:-0.3.1}
+VERSION=${VERSION:-0.6.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,11 +69,19 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# avoid install man page over setup.py
+sed -i 's/if "install"/if ""/' setup.py
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# install man page
+mkdir -p $PKG/usr/man/man1
+gzip -9 man/$PRGNAM.1
+install -D -m0644 man/$PRGNAM.1.gz $PKG/usr/man/man1/$PRGNAM.1.gz
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.rst CHANGELOG LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/pysed/pysed.info b/python/pysed/pysed.info
index f0ba9707c4..0d1b91510a 100644
--- a/python/pysed/pysed.info
+++ b/python/pysed/pysed.info
@@ -1,8 +1,8 @@
PRGNAM="pysed"
-VERSION="0.3.1"
+VERSION="0.6.2"
HOMEPAGE="https://github.com/dslackw/pysed"
-DOWNLOAD="https://github.com/dslackw/pysed/archive/v0.3.1.tar.gz"
-MD5SUM="168a3aeb674205adb51e848b29414fb1"
+DOWNLOAD="https://github.com/dslackw/pysed/archive/v0.6.2.tar.gz"
+MD5SUM="54248417a90487383bd77e700c722427"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/python/pysed/slack-desc b/python/pysed/slack-desc
index f4b23a57d8..c86e200b00 100644
--- a/python/pysed/slack-desc
+++ b/python/pysed/slack-desc
@@ -11,7 +11,7 @@ pysed:
pysed: Pysed is a Python stream editor, is used to perform basic text
pysed: ransformations from a file. It reads text, line by line, from
pysed: a file and replace, insert or print all text or specific area.
-pysed: One of the elements of distinction is the use of colors.
+pysed: Actually pysed is a passage of Python module ‘re’ in terminal.
pysed:
pysed: Homepage: https://github.com/dslackw/pysed
pysed: