summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Adis Nezirović2015-01-22 00:39:57 +0100
committer Willy Sudiarto Raharjo2015-01-22 00:39:57 +0100
commitf68dead15077c8735e9f669ceeb175e17adb0ded (patch)
treeb2939015b67928c2088d742adb73d85180dd9fde
parent2c03ec36ea444083e243730370559aa8b7c8790b (diff)
downloadslackbuilds-f68dead15077c8735e9f669ceeb175e17adb0ded.tar.gz
libraries/gevent: Updated for version 1.0.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/gevent/gevent.SlackBuild19
-rw-r--r--libraries/gevent/gevent.info6
2 files changed, 11 insertions, 14 deletions
diff --git a/libraries/gevent/gevent.SlackBuild b/libraries/gevent/gevent.SlackBuild
index b8787d4fdc..adcfadc1ce 100644
--- a/libraries/gevent/gevent.SlackBuild
+++ b/libraries/gevent/gevent.SlackBuild
@@ -1,11 +1,11 @@
#!/bin/sh
-# Slackware build script for Greenlet
+# Slackware build script for Gevent
#
-# $Revision: daafc514725c $
-# $Date: 2014/01/03 20:39:33 $
+# $Revision: fbd2bb006bbd $
+# $Date: 2015/01/21 22:22:35 $
#
-# Copyright 2014 Adis Nezirović <adis_at_linux.org.ba>
+# Copyright (C) 2014-2015 Adis Nezirovic <adis_at_linux.org.ba>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gevent
-VERSION=${VERSION:-1.0}
+VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,7 +57,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -70,18 +70,15 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-# Strip binaries and libraries.
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS LICENSE README.rst TODO changelog.rst doc/*.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE README.rst TODO changelog.rst doc/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/gevent/gevent.info b/libraries/gevent/gevent.info
index 2cc678319d..ac1aeb69ca 100644
--- a/libraries/gevent/gevent.info
+++ b/libraries/gevent/gevent.info
@@ -1,8 +1,8 @@
PRGNAM="gevent"
-VERSION="1.0"
+VERSION="1.0.1"
HOMEPAGE="http://www.gevent.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/g/gevent/gevent-1.0.tar.gz"
-MD5SUM="33aef51a06268f5903fea378e1388e4d"
+DOWNLOAD="https://pypi.python.org/packages/source/g/gevent/gevent-1.0.1.tar.gz"
+MD5SUM="7b952591d1a0174d6eb6ac47bd975ab6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="greenlet"