summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Panagiotis Nikolaou2015-01-18 02:27:43 +0100
committer Willy Sudiarto Raharjo2015-01-18 02:27:43 +0100
commitb9d04f9b8564bf4305985bb90089d6a176863eab (patch)
tree2318452ff58f5093c58663381eb63140240139b4
parentb601e94ea24f2f489072ad75878a687001555e8b (diff)
downloadslackbuilds-b9d04f9b8564bf4305985bb90089d6a176863eab.tar.gz
development/osmo-sdr: Added (toolkit for building SDRs).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/osmo-sdr/README13
-rw-r--r--development/osmo-sdr/osmo-sdr.SlackBuild96
-rw-r--r--development/osmo-sdr/osmo-sdr.info10
-rw-r--r--development/osmo-sdr/slack-desc19
4 files changed, 138 insertions, 0 deletions
diff --git a/development/osmo-sdr/README b/development/osmo-sdr/README
new file mode 100644
index 0000000000..2d1fe0c6ee
--- /dev/null
+++ b/development/osmo-sdr/README
@@ -0,0 +1,13 @@
+OsmoSDR is a 100% Free Software based small form-factor
+inexpensive SDR (Software Defined Radio) project.
+
+If you are familiar with existing SDR receivers,
+then OsmoSDR can be thought of something in between
+a ​FunCube Dongle (only 96kHz bandwidth) and a USRP
+(much more expensive).
+For a very cheap SDR (with limited dynamic range),
+you can use the DVB-T USB stick using the RTL2832U chip,
+as documented in rtl-sdr.
+
+It consists of a USB-attached Hardware, associated Firmware
+as well as GrOsmoSDR gnuradio integration on the PC.
diff --git a/development/osmo-sdr/osmo-sdr.SlackBuild b/development/osmo-sdr/osmo-sdr.SlackBuild
new file mode 100644
index 0000000000..688b039583
--- /dev/null
+++ b/development/osmo-sdr/osmo-sdr.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/sh
+
+# Slackware build script for gr-osmosdr
+
+# Copyright 2015 Panagiotis Nikolaou, Karlovasi Samos, Gr
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=osmo-sdr
+VERSION=${VERSION:-0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION/software/libosmosdr/
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s|lib/pkgconfig|lib${LIBDIRSUFFIX}/pkgconfig|" CMakeLists.txt
+mkdir -p build
+cd build
+cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr/ \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/osmo-sdr/osmo-sdr.info b/development/osmo-sdr/osmo-sdr.info
new file mode 100644
index 0000000000..8ba7d925a6
--- /dev/null
+++ b/development/osmo-sdr/osmo-sdr.info
@@ -0,0 +1,10 @@
+PRGNAM="osmo-sdr"
+VERSION="0.1"
+HOMEPAGE="http://sdr.osmocom.org/trac/"
+DOWNLOAD="http://cgit.osmocom.org/osmo-sdr/snapshot/osmo-sdr-0.1.tar.gz"
+MD5SUM="79351554ec5cff043de17386215f59c3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Panagiotis Nikolaou"
+EMAIL="hostmaster@slackonly.com"
diff --git a/development/osmo-sdr/slack-desc b/development/osmo-sdr/slack-desc
new file mode 100644
index 0000000000..a3bc85a97d
--- /dev/null
+++ b/development/osmo-sdr/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+osmo-sdr: osmo-sdr (free software toolkit for building SDRs)
+osmo-sdr:
+osmo-sdr: OsmoSDR is a 100% Free Software based small form-factor
+osmo-sdr: inexpensive SDR (Software Defined Radio) project.
+osmo-sdr: If you are familiar with existing SDR receivers,
+osmo-sdr: then OsmoSDR can be thought of something in between a
+osmo-sdr: FunCube Dongle (only 96kHz bandwidth) and a USRP
+osmo-sdr: (much more expensive)
+osmo-sdr:
+osmo-sdr: homepage: http://sdr.osmocom.org/trac/
+osmo-sdr: