summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Panagiotis Nikolaou2015-01-18 02:11:09 +0100
committer Willy Sudiarto Raharjo2015-01-18 02:11:09 +0100
commitb601e94ea24f2f489072ad75878a687001555e8b (patch)
tree9877b96bb22c34cbba92ddabad3bf8b5bf096b58
parent1494af9d3062af2462758139b1972c645676fc72 (diff)
downloadslackbuilds-b601e94ea24f2f489072ad75878a687001555e8b.tar.gz
development/hackrf: Added (radio platform).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/hackrf/README9
-rw-r--r--development/hackrf/hackrf.SlackBuild104
-rw-r--r--development/hackrf/hackrf.info10
-rw-r--r--development/hackrf/slack-desc19
4 files changed, 142 insertions, 0 deletions
diff --git a/development/hackrf/README b/development/hackrf/README
new file mode 100644
index 0000000000..1135bd535d
--- /dev/null
+++ b/development/hackrf/README
@@ -0,0 +1,9 @@
+This is the host software for hackrf, a project to produce
+a low cost, open source software radio platform.
+
+Below are some paramaters that can be passed to the slackbuild
+to turn on some optional components.
+
+RULES=yes|no (Default is no) In order to be able to use the
+dongle as a non-root user, you may install the appropriate
+udev rules
diff --git a/development/hackrf/hackrf.SlackBuild b/development/hackrf/hackrf.SlackBuild
new file mode 100644
index 0000000000..45a255d915
--- /dev/null
+++ b/development/hackrf/hackrf.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/sh
+
+# Slackware build script for hackrf
+
+# Copyright 2015 Panagiotis Nikolaou, Karlovasi Samos, Gr
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=hackrf
+VERSION=${VERSION:-2014.08.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+
+# Use the dongle as a non-root user.
+if [ "${RULES:-no}" == "yes" ]; then
+ OPT1="$OPT -DINSTALL_UDEV_RULES=ON"
+fi
+
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION/host
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s|lib/pkgconfig|lib${LIBDIRSUFFIX}/pkgconfig|" libhackrf/CMakeLists.txt
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ $OPT1 \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_SUFFIX=$LIBDIRSUFFIX ..
+ make
+make install DESTDIR=$PKG
+cd ../..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a TRADEMARK COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/hackrf/hackrf.info b/development/hackrf/hackrf.info
new file mode 100644
index 0000000000..493003ba5f
--- /dev/null
+++ b/development/hackrf/hackrf.info
@@ -0,0 +1,10 @@
+PRGNAM="hackrf"
+VERSION="2014.08.1"
+HOMEPAGE="https://github.com/mossmann/hackrf"
+DOWNLOAD="https://slackonly.com/pub/sources/development/hackrf/hackrf-2014.08.1.tar.gz"
+MD5SUM="574af2e4a2afa1fca6d4c55f8b0d399c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Panagiotis Nikolaou"
+EMAIL="hostmaster@slackonly.com"
diff --git a/development/hackrf/slack-desc b/development/hackrf/slack-desc
new file mode 100644
index 0000000000..b34786fed0
--- /dev/null
+++ b/development/hackrf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hackrf: hackrf (radio platform)
+hackrf:
+hackrf: HackRF, a project to produce a low cost, open source software
+hackrf: radio platform.
+hackrf:
+hackrf: homepage: https://github.com/mossmann/hackrf
+hackrf:
+hackrf:
+hackrf:
+hackrf:
+hackrf: