summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author ArTourter2015-01-06 17:10:03 +0100
committer Willy Sudiarto Raharjo2015-01-06 17:10:03 +0100
commita7de720aea4198479d934b145b2ddcd6a76aa6fa (patch)
tree16e5306f5b926e4d796c476b9396bc1b822be625
parentc54af72ec77a19173f338f024693965a83cf74e7 (diff)
downloadslackbuilds-a7de720aea4198479d934b145b2ddcd6a76aa6fa.tar.gz
multimedia/cuetools: Updated for version 1.4.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--multimedia/cuetools/cuetag-fix_spaces.diff46
-rw-r--r--multimedia/cuetools/cuetools.SlackBuild35
-rw-r--r--multimedia/cuetools/cuetools.info8
-rw-r--r--multimedia/cuetools/fix_build_with_automake-1.12.diff24
-rw-r--r--multimedia/cuetools/slack-desc14
5 files changed, 98 insertions, 29 deletions
diff --git a/multimedia/cuetools/cuetag-fix_spaces.diff b/multimedia/cuetools/cuetag-fix_spaces.diff
new file mode 100644
index 0000000000..f240e9d375
--- /dev/null
+++ b/multimedia/cuetools/cuetag-fix_spaces.diff
@@ -0,0 +1,46 @@
+From 21ee6cc40f02693928efbc4f3beeb681950c16b5 Mon Sep 17 00:00:00 2001
+From: Svend Sorensen <svend@ciffer.net>
+Date: Sat, 23 Nov 2013 17:23:01 -0800
+Subject: [PATCH] cuetag: Fix handling of spaces in file names
+
+Fixes #14
+---
+ src/tools/cuetag.sh | 9 ++++-----
+ 1 file changed, 4 insertions(+), 5 deletions(-)
+
+diff --git a/src/tools/cuetag.sh b/src/tools/cuetag.sh
+index f26fa20..448920f 100755
+--- a/src/tools/cuetag.sh
++++ b/src/tools/cuetag.sh
+@@ -182,16 +182,15 @@ main()
+ ntrack=$(cueprint -d '%N' "$cue_file")
+ trackno=1
+
+- FILES= FIELDS=
++ NUM_FILES=0 FIELDS=
+ for arg in "$@"; do
+ case "$arg" in
+- *.*) FILES="$FILES $arg";;
++ *.*) NUM_FILES=$(expr $NUM_FILES + 1);;
+ *) FIELDS="$FIELDS $arg";;
+ esac
+ done
+
+- set -- $FILES
+- if [ $# -ne $ntrack ]; then
++ if [ $NUM_FILES -ne $ntrack ]; then
+ echo "warning: number of files does not match number of tracks"
+ fi
+
+@@ -209,7 +208,7 @@ main()
+ *.[Tt][Xx][Tt])
+ vorbis $trackno "$file"
+ ;;
+- *)
++ *.*)
+ echo "$file: uknown file type"
+ ;;
+ esac
+--
+1.8.5.1
+
diff --git a/multimedia/cuetools/cuetools.SlackBuild b/multimedia/cuetools/cuetools.SlackBuild
index 13f4f2469e..bc2a660340 100644
--- a/multimedia/cuetools/cuetools.SlackBuild
+++ b/multimedia/cuetools/cuetools.SlackBuild
@@ -17,8 +17,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=cuetools
-VERSION=${VERSION:-1.3.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.4.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -54,20 +54,23 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Patching the cuetag script in extras with patch from Archlinux
-# Thanks to Gilcio Amaral-Martins <gilcio.amaral@gmail.com> for the suggestion
-patch -Np0 < $CWD/cuetag.patch
- sed -i -e 's/--import-vc-from/--import-tags-from/' \
- -e 's/--remove-vc-all/--remove-all-tags/' extras/cuetag.sh
+# Patching with patches from Archlinux
+patch -Np1 < "$CWD/fix_build_with_automake-1.12.diff"
+patch -Np1 < "$CWD/cuetag-fix_spaces.diff"
+
+aclocal
+autoheader
+automake --force-missing --add-missing
+autoconf
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -82,18 +85,14 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-install -m755 extras/cuetag.sh $PKG/usr/bin/cuetag
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS ChangeLog COPYING INSTALL NEWS README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING NEWS README TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/multimedia/cuetools/cuetools.info b/multimedia/cuetools/cuetools.info
index 33dc4a6f15..1d1e831877 100644
--- a/multimedia/cuetools/cuetools.info
+++ b/multimedia/cuetools/cuetools.info
@@ -1,8 +1,8 @@
PRGNAM="cuetools"
-VERSION="1.3.1"
-HOMEPAGE="http://sourceforge.net/projects/cuetools.berlios/"
-DOWNLOAD="http://sourceforge.net/projects/cuetools.berlios/files/cuetools-1.3.1.tar.gz"
-MD5SUM="45575f7a1bdc6615599fa6cb49845cca"
+VERSION="1.4.0"
+HOMEPAGE="https://github.com/svend/cuetools"
+DOWNLOAD="https://github.com/svend/cuetools/archive/1.4.0.tar.gz"
+MD5SUM="4492dae2b3f9e077f6455a1f1cddef3b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/multimedia/cuetools/fix_build_with_automake-1.12.diff b/multimedia/cuetools/fix_build_with_automake-1.12.diff
new file mode 100644
index 0000000000..9090f32c3d
--- /dev/null
+++ b/multimedia/cuetools/fix_build_with_automake-1.12.diff
@@ -0,0 +1,24 @@
+From 761eba5b9b9c87a872a18b7ba4bf3d77a96e2157 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Horv=C3=A1th=20Bal=C3=A1zs?= <q@qroa.ch>
+Date: Tue, 15 Oct 2013 01:17:52 +0200
+Subject: [PATCH] Fix build with automake-1.12.
+
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configure.ac b/configure.ac
+index f54bb92..9f36932 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,6 +4,7 @@ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+ AM_PROG_LEX
++m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
+ AC_PROG_YACC
+ AC_CONFIG_HEADERS([config.h])
+ AC_CONFIG_FILES([Makefile doc/Makefile src/Makefile src/lib/Makefile src/tools/Makefile extras/Makefile])
+--
+1.8.4
+
diff --git a/multimedia/cuetools/slack-desc b/multimedia/cuetools/slack-desc
index 033be1b45b..a1103450c0 100644
--- a/multimedia/cuetools/slack-desc
+++ b/multimedia/cuetools/slack-desc
@@ -1,15 +1,15 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
cuetools: cuetools (cue and toc file parsers and utilities)
cuetools:
-cuetools: cuetools is a set of utilities for working with Cue Sheet (cue) and
-cuetools: Table of Contents (toc) files.
+cuetools: cuetools is a set of utilities for working with Cue Sheet (cue) and
+cuetools: Table of Contents (toc) files.
cuetools:
cuetools: Homepage: http://developer.berlios.de/projects/cuetools/
cuetools: