summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Barry J. Grundy2014-12-04 22:24:52 +0100
committer Willy Sudiarto Raharjo2014-12-04 22:24:52 +0100
commit883caa847261efc839095b58093ce0beb6f31daf (patch)
treead77627f1d5df761c6ee6c8d0cee7e958eb31d40
parentb3e2deedaa0a3a67f7ba3be4a6eb7fb8b2e987d1 (diff)
downloadslackbuilds-883caa847261efc839095b58093ce0beb6f31daf.tar.gz
python/binplist: Added (list parser module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/binplist/README3
-rw-r--r--python/binplist/binplist.SlackBuild85
-rw-r--r--python/binplist/binplist.info10
-rw-r--r--python/binplist/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/binplist/README b/python/binplist/README
new file mode 100644
index 0000000000..51a61a2871
--- /dev/null
+++ b/python/binplist/README
@@ -0,0 +1,3 @@
+binplist (python module)
+
+A binary property list (plist) parser module written in python.
diff --git a/python/binplist/binplist.SlackBuild b/python/binplist/binplist.SlackBuild
new file mode 100644
index 0000000000..eea29c15e7
--- /dev/null
+++ b/python/binplist/binplist.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for binplist
+# Copyright 2014 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Initial Build - November 2014 version 0.1.4
+
+PRGNAM=binplist
+VERSION=${VERSION:-0.1.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
+ -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/binplist/binplist.info b/python/binplist/binplist.info
new file mode 100644
index 0000000000..341f56a43b
--- /dev/null
+++ b/python/binplist/binplist.info
@@ -0,0 +1,10 @@
+PRGNAM="binplist"
+VERSION="0.1.4"
+HOMEPAGE="https://code.google.com/p/binplist/"
+DOWNLOAD="https://binplist.googlecode.com/files/binplist-0.1.4.tar.gz"
+MD5SUM="5c4788a9731b67487790109910380699"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/binplist/slack-desc b/python/binplist/slack-desc
new file mode 100644
index 0000000000..b8bd0ed639
--- /dev/null
+++ b/python/binplist/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+binplist: binplist (list parser module)
+binplist:
+binplist: A binary property list (plist) parser module written in python.
+binplist:
+binplist: https://code.google.com/p/binplist/
+binplist:
+binplist:
+binplist:
+binplist:
+binplist:
+binplist: