summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author klaatu2014-10-22 18:17:36 +0200
committer Willy Sudiarto Raharjo2014-10-22 18:17:36 +0200
commit6561d970d5297dbe2271bf3c556c9ce33b82e4a8 (patch)
tree702da775797c6896a01d9156364462bacb494ee3
parent34d3a5c938eb7ca508c37f466979ce4a1dd7fc4c (diff)
downloadslackbuilds-6561d970d5297dbe2271bf3c556c9ce33b82e4a8.tar.gz
libraries/SFGUI: Added (Simple and Fast GUI).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/SFGUI/README3
-rw-r--r--libraries/SFGUI/SFGUI.SlackBuild87
-rw-r--r--libraries/SFGUI/SFGUI.info10
-rw-r--r--libraries/SFGUI/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/libraries/SFGUI/README b/libraries/SFGUI/README
new file mode 100644
index 0000000000..18299c1703
--- /dev/null
+++ b/libraries/SFGUI/README
@@ -0,0 +1,3 @@
+SFGUI (Simple and Fast Graphical User Interface) is a fast, simple and native C++ GUI library for SFML.
+
+It provides a rich set of widgets and is highly customizable in its looks. The library has been designed with flexibility and extensibility in mind and provides a modern and clean C++ API.
diff --git a/libraries/SFGUI/SFGUI.SlackBuild b/libraries/SFGUI/SFGUI.SlackBuild
new file mode 100644
index 0000000000..2f13a2953c
--- /dev/null
+++ b/libraries/SFGUI/SFGUI.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+#
+# Slackware build script for SFGUI
+# Copyright 2014 klaatu@member.fsf.org
+#
+# GNU All-Permissive License
+# Copying and distribution of this file, with or without modification,
+# are permitted in any medium without royalty provided the copyright
+# notice and this notice are preserved. This file is offered as-is,
+# without any warranty.
+
+PRGNAM=SFGUI
+VERSION=${VERSION:-0.2.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION-source.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+
+# -DLIB_SUFFIX is ignored. Patch CMakeLists as needed.
+ sed -i 's%/lib/%/lib64/%g' cmake_install.cmake || exit
+ sed -i 's%/lib"%/lib64/"%g' cmake_install.cmake || exit
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README CHANGELOG FONT.LICENSE LICENSE AUTHORS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/SFGUI/SFGUI.info b/libraries/SFGUI/SFGUI.info
new file mode 100644
index 0000000000..b72639e4eb
--- /dev/null
+++ b/libraries/SFGUI/SFGUI.info
@@ -0,0 +1,10 @@
+PRGNAM="SFGUI"
+VERSION="0.2.3"
+HOMEPAGE="http://sfgui.sfml-dev.de/p/"
+DOWNLOAD="http://sfgui.sfml-dev.de/public_root/downloads/SFGUI-0.2.3-source.zip"
+MD5SUM="93934fb0bea9723b6e3f7468ad6c6f95"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="SFML"
+MAINTAINER="klaatu"
+EMAIL="klaatu@member.fsf.org"
diff --git a/libraries/SFGUI/slack-desc b/libraries/SFGUI/slack-desc
new file mode 100644
index 0000000000..6417c49c4b
--- /dev/null
+++ b/libraries/SFGUI/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+SFGUI: SFGUI (Simple and Fast Graphical User Interface)
+SFGUI:
+SFGUI: A fast, simple, and native C++ GUI library for SFML. SFGUI provides
+SFGUI: a rich set of widgets and is highly customisable in appearance.
+SFGUI:
+SFGUI: SFGUI is distributed under the zlib license, allowing it to be used
+SFGUI: in both open and non-open source projects.
+SFGUI:
+SFGUI: http://sfgui.sfml-dev.de/p/
+SFGUI:
+SFGUI: