summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2014-09-05 02:14:01 +0200
committer Willy Sudiarto Raharjo2014-09-05 19:02:52 +0200
commit5aca0439cbcd16cdaf5c444f1fed3280bfe71366 (patch)
tree5645b30e7671fbffd1434d8c26de1e75528fee10
parentbf9ed6416edf191fe7989f13eea2e864299c2511 (diff)
downloadslackbuilds-5aca0439cbcd16cdaf5c444f1fed3280bfe71366.tar.gz
system/vinterm: Added (terminal emulator).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/vinterm/README19
-rw-r--r--system/vinterm/doinst.sh3
-rw-r--r--system/vinterm/slack-desc19
-rw-r--r--system/vinterm/vinterm.SlackBuild87
-rw-r--r--system/vinterm/vinterm.info12
5 files changed, 140 insertions, 0 deletions
diff --git a/system/vinterm/README b/system/vinterm/README
new file mode 100644
index 0000000000..2d243e7aa1
--- /dev/null
+++ b/system/vinterm/README
@@ -0,0 +1,19 @@
+vinterm (terminal emulator that simulates 1980s CRT appearance)
+
+Use a terminal in style, like in the good old days! Vintage Terminal is
+a terminal emulator that simulates the looks of a 1980s monitor.
+
+Vintage Terminal has the following features:
+
+- Full terminal capabilities implemented;
+- Scaling (zoom) with the argument -s;
+- Window resize/maximize;
+- Full screen (CTRL + F11) and full screen with 80 columns (CTRL + SHIFT + F11);
+- UNICODE support (no unicode font yet);
+- Terminal rollback;
+- Mouse support (new in 0.5.0);
+- Has a authentic old look based on a IBM 5151 monitor.
+
+The package includes a vim color scheme by the vinterm author that's
+meant to make vim's syntax highlighting look better in vinterm. To use
+it in vim, enter ":colorscheme vinterm" (or load it from your .vimrc).
diff --git a/system/vinterm/doinst.sh b/system/vinterm/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/system/vinterm/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/system/vinterm/slack-desc b/system/vinterm/slack-desc
new file mode 100644
index 0000000000..2fb434ce50
--- /dev/null
+++ b/system/vinterm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+vinterm: vinterm (terminal emulator that simulates 1980s CRT appearance)
+vinterm:
+vinterm: Use a terminal in style, like in the good old days! Vintage Terminal
+vinterm: is a terminal emulator that simulates the looks of a 1980s monitor.
+vinterm:
+vinterm:
+vinterm:
+vinterm:
+vinterm:
+vinterm:
+vinterm:
diff --git a/system/vinterm/vinterm.SlackBuild b/system/vinterm/vinterm.SlackBuild
new file mode 100644
index 0000000000..26078e2f5c
--- /dev/null
+++ b/system/vinterm/vinterm.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for vinterm
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=vinterm
+VERSION=${VERSION:-0.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e "s,-Os,$SLKCFLAGS," -e "s,usr/lib,usr/lib$LIBDIRSUFFIX," config.mk
+
+export TERMINFO=$PKG/usr/share/terminfo
+mkdir -p $TERMINFO
+make all install DEBUG=no DESTDIR=$PKG PREFIX=/usr MANPREFIX=/usr/man
+
+# exe already stripped
+gzip $PKG/usr/man/man1/$PRGNAM.1
+
+mkdir -p $PKG/usr/share/applications
+ln -s ../$PRGNAM/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+
+mkdir -p $PKG/usr/share/pixmaps
+cat icon/icon_128.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+
+# the vim theme is distributed separately, include it the package.
+# the vim dir has the version number, we assume the build host's vim
+# is the same version as the target's.
+VIMDIR=$( /bin/ls -d /usr/share/vim/vim?? | head -1 )
+mkdir -p $PKG/$VIMDIR/colors
+cat $CWD/$PRGNAM.vim > $PKG/$VIMDIR/colors/$PRGNAM.vim
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS HACKING LICENSE NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/vinterm/vinterm.info b/system/vinterm/vinterm.info
new file mode 100644
index 0000000000..67604aebc8
--- /dev/null
+++ b/system/vinterm/vinterm.info
@@ -0,0 +1,12 @@
+PRGNAM="vinterm"
+VERSION="0.5.0"
+HOMEPAGE="http://code.google.com/p/vinterm/"
+DOWNLOAD="http://vinterm.googlecode.com/files/vinterm-0.5.0.tar.gz \
+ http://vinterm.googlecode.com/files/vinterm.vim"
+MD5SUM="307d2285565d9699d62bfc72b8e445c3 \
+ 15fd1ef04deb529f3aad5aa11b5d1bf4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libconfig"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"