summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2014-02-17 09:41:49 +0100
committer Erik Hanson2014-02-18 21:59:54 +0100
commit0bba16a5a69fc285f0ce443c48d59d1e5dd15b7d (patch)
tree3b112a5fd546fdcd292145ccd260f0b396b63b28
parentf9bc4c080e91c7581fcc4c649338608ed88dc0c2 (diff)
downloadslackbuilds-0bba16a5a69fc285f0ce443c48d59d1e5dd15b7d.tar.gz
python/python-keyczar: Added (cryptographic toolkit).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-keyczar/README3
-rw-r--r--python/python-keyczar/python-keyczar.SlackBuild75
-rw-r--r--python/python-keyczar/python-keyczar.info10
-rw-r--r--python/python-keyczar/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/python/python-keyczar/README b/python/python-keyczar/README
new file mode 100644
index 0000000000..01b7e97aa4
--- /dev/null
+++ b/python/python-keyczar/README
@@ -0,0 +1,3 @@
+Keyczar is an open source cryptographic toolkit designed to make it easier and
+safer for developers to use cryptography in their applications. Keyczar supports
+authentication and encryption with both symmetric and asymmetric keys.
diff --git a/python/python-keyczar/python-keyczar.SlackBuild b/python/python-keyczar/python-keyczar.SlackBuild
new file mode 100644
index 0000000000..5f15fac919
--- /dev/null
+++ b/python/python-keyczar/python-keyczar.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for python-keyczar
+
+# Copyright 2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-keyczar
+VERSION=${VERSION:-0.71c}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+rm -rf ${PRGNAM/-/_}.egg-info
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog LICENSE PKG-INFO README doc/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-keyczar/python-keyczar.info b/python/python-keyczar/python-keyczar.info
new file mode 100644
index 0000000000..f2d50d464a
--- /dev/null
+++ b/python/python-keyczar/python-keyczar.info
@@ -0,0 +1,10 @@
+PRGNAM="python-keyczar"
+VERSION="0.71c"
+HOMEPAGE="http://www.keyczar.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/p/python-keyczar/python-keyczar-0.71c.tar.gz"
+MD5SUM="e7483709eb95aac46f441f84f4ae8780"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools pyasn1 pycrypto"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/python-keyczar/slack-desc b/python/python-keyczar/slack-desc
new file mode 100644
index 0000000000..2a307452ce
--- /dev/null
+++ b/python/python-keyczar/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-keyczar: python-keyczar (cryptographic toolkit)
+python-keyczar:
+python-keyczar: Keyczar is an open source cryptographic toolkit designed to make it
+python-keyczar: easier and safer for developers to use cryptography in their
+python-keyczar: applications. Keyczar supports authentication and encryption with both
+python-keyczar: symmetric and asymmetric keys.
+python-keyczar:
+python-keyczar: Homepage: http://www.keyczar.org/
+python-keyczar:
+python-keyczar:
+python-keyczar: