summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Heinz Wiesinger2010-05-13 00:06:04 +0200
committer Heinz Wiesinger2010-05-13 00:06:04 +0200
commitf6707bef60bd2bc2da51f786d1aefddd3b7bc648 (patch)
tree929f1b532f53c35aac2eeabfa525abba8e6a71f7
parentccd0f5d5ce99278323532d87650805f472e1a235 (diff)
downloadslackbuilds-f6707bef60bd2bc2da51f786d1aefddd3b7bc648.tar.gz
business/xtuple: Removed from 13.0 repository
-rw-r--r--business/xtuple/README17
-rw-r--r--business/xtuple/doinst.sh9
-rw-r--r--business/xtuple/init.sql21
-rw-r--r--business/xtuple/slack-desc19
-rw-r--r--business/xtuple/xtuple.SlackBuild114
-rw-r--r--business/xtuple/xtuple.desktop11
-rw-r--r--business/xtuple/xtuple.info8
7 files changed, 0 insertions, 199 deletions
diff --git a/business/xtuple/README b/business/xtuple/README
deleted file mode 100644
index f8df86c7a7..0000000000
--- a/business/xtuple/README
+++ /dev/null
@@ -1,17 +0,0 @@
-Fully integrated ERP, CRM, and accounting for small to midsized
-businesses. Business logic resides in PostgreSQL database server.
-Fully international-ready.
-
-For xtuple to work correctly you need to setup postgresql.
-Issuing the following commands should be enough:
- psql -U postgres -f /usr/share/xtuple/init.sql
- createdb -U mfgadmin NEW_DATABASE_NAME
- pg_restore -U mfgadmin -d NEW_DATABASE_NAME postbooks_quickstart.backup -v
-
-The "postbooks_quickstart.backup" file is one of three schemas available
-on http://www.sourceforge.net/projects/postbooks/. The others
-are "postbooks_demo.backup" and "postbooks_empty.backup". You will have to
-choose one of these depending on your needs.
-
-Requires qt4, openrpt and postgresql (runtime dependency). All of which
-are available from SlackBuilds.org. \ No newline at end of file
diff --git a/business/xtuple/doinst.sh b/business/xtuple/doinst.sh
deleted file mode 100644
index 1d85d0e8d5..0000000000
--- a/business/xtuple/doinst.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/gtk-update-icon-cache ] \
- && [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
-fi
-
diff --git a/business/xtuple/init.sql b/business/xtuple/init.sql
deleted file mode 100644
index 9076151b68..0000000000
--- a/business/xtuple/init.sql
+++ /dev/null
@@ -1,21 +0,0 @@
---
--- This script creates the group openmfg and the user mfgadmin
---
-
---
--- Create the openmfg group
---
-CREATE GROUP openmfg;
-
---
--- Create the mfgadmin user with createdb and createuser
--- permissions. Place the user in the openmfg group and
--- set the password to the default of mfgadmin.
---
-CREATE USER mfgadmin WITH PASSWORD 'mfgadmin'
- CREATEDB CREATEUSER
- IN GROUP openmfg;
-CREATE USER admin WITH PASSWORD 'admin'
- CREATEDB CREATEUSER
- IN GROUP openmfg;
-
diff --git a/business/xtuple/slack-desc b/business/xtuple/slack-desc
deleted file mode 100644
index 461b44008b..0000000000
--- a/business/xtuple/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler--------------------------------------------------|
-xtuple: xtuple (ERP, CRM, accounting for SMEs - Postbooks Edition)
-xtuple:
-xtuple: Fully integrated ERP, CRM, and accounting for small to midsized
-xtuple: businesses. Business logic resides in PostgreSQL database server.
-xtuple: Fully international-ready.
-xtuple:
-xtuple: Homepage: http://www.postbooks.org/
-xtuple:
-xtuple:
-xtuple:
-xtuple:
diff --git a/business/xtuple/xtuple.SlackBuild b/business/xtuple/xtuple.SlackBuild
deleted file mode 100644
index 7393dc208f..0000000000
--- a/business/xtuple/xtuple.SlackBuild
+++ /dev/null
@@ -1,114 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for xtuple
-
-# Copyright 2008 Heinz Wiesinger <pprkut@liwjatan.at>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=xtuple
-VERSION=3.0.1
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION-source
-tar xvf $CWD/$PRGNAM-$VERSION-source.tar.bz2
-cd $PRGNAM-$VERSION-source
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-cd xtuple
- qmake-qt4 OPENRPT_DIR=/usr/include/openrpt
-
- make qmake_all
-
- for i in common/Makefile widgets/Makefile \
- widgets/Makefile.dll guiclient/Makefile; do
- sed -i "s/-O2/$SLKCFLAGS/" $i
- sed -i "s|..//usr/include/|/usr/include/|g" $i
- done
-
- dest="DESTDIR = \$(DESTDIR)"
- qtversion=$(ls -l /usr/lib/qt4 | cut -d "-" -f 5 | cut -d "/" -f 1)
-
- # libxtuplewidgets.so is installed during make, so we change the path here
- # so that it's included in the package
- sed -i "s|/usr/lib/qt-$qtversion/plugins/designer/|$\(DESTDIR\) |g" \
- widgets/Makefile.dll
-
- # As long as we rely on SBo's version of qt4, place the designer-plugin
- # in qt-$qtversion, as it's easier on upgrades. Once we rely on slackware's
- # qt4 this can be changed to something more accurate.
- sed -i "s|$dest|DESTDIR = $PKG/usr/lib/qt-$qtversion/plugins/designer/|" \
- widgets/Makefile.dll
-
- make
-
- mkdir -p $PKG/usr/bin $PKG/usr/share/xtuple
-
- install -m 0755 bin/* $PKG/usr/bin/
-
-cd -
-
-mkdir -p $PKG/usr/share/applications
-
-install -m 0644 $CWD/xtuple.desktop \
- $PKG/usr/share/applications/xtuple.desktop
-
-for i in 16 32 48 128; do
- mkdir -p $PKG/usr/share/icons/hicolor/${i}x${i}/apps
- install -m 0644 xtuple/guiclient/images/icon${i}x32.png \
- $PKG/usr/share/icons/hicolor/${i}x${i}/apps/xtuple.png
-done
-
-cp -f $CWD/init.sql $PKG/usr/share/xtuple/init.sql
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a INSTALL.TXT LICENSE.txt README_FIRST.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/business/xtuple/xtuple.desktop b/business/xtuple/xtuple.desktop
deleted file mode 100644
index 1475aca809..0000000000
--- a/business/xtuple/xtuple.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Name=xTuple - Postbooks Edition
-GenericName=Enterprise Resource Planning
-Comment=ERP, CRM and Accounting for SMEs
-Exec=xtuple
-Icon=xtuple.png
-Terminal=false
-Type=Application
-Categories=Application;Office
-StartupNotify=true
diff --git a/business/xtuple/xtuple.info b/business/xtuple/xtuple.info
deleted file mode 100644
index 45668dbebd..0000000000
--- a/business/xtuple/xtuple.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="xtuple"
-VERSION="3.0.1"
-HOMEPAGE="http://www.postbooks.org/"
-DOWNLOAD="http://downloads.sourceforge.net/postbooks/xtuple-3.0.1-source.tar.bz2"
-MD5SUM="ebeed405631b4bf72edbdad199db3e30"
-MAINTAINER="ppr:kut"
-EMAIL="pprkut@liwjatan.at"
-APPROVED="David Somero" \ No newline at end of file