summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-02-13 11:05:57 +0100
committer Willy Sudiarto Raharjo2014-02-13 19:33:13 +0100
commit754fdd0796535f307b54105fc58691f45b167f7e (patch)
tree7cfb016077f016c443ad39940eae01fe6a3ac808
parent0ed1accf7ccbb06bf7bfd61078af2fbdc7e99087 (diff)
downloadslackbuilds-754fdd0796535f307b54105fc58691f45b167f7e.tar.gz
network/deis: Added (Command-line Client for Deis).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/deis/README5
-rw-r--r--network/deis/deis.SlackBuild85
-rw-r--r--network/deis/deis.info10
-rw-r--r--network/deis/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/network/deis/README b/network/deis/README
new file mode 100644
index 0000000000..0d9799db91
--- /dev/null
+++ b/network/deis/README
@@ -0,0 +1,5 @@
+Deis is a Django/Celery API server, Python CLI and set of Chef cookbooks
+that combine to provide a Heroku-inspired application platform for
+public and private clouds.
+
+Your PaaS. Your Rules.
diff --git a/network/deis/deis.SlackBuild b/network/deis/deis.SlackBuild
new file mode 100644
index 0000000000..fa2562a5cb
--- /dev/null
+++ b/network/deis/deis.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for deis
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=deis
+VERSION=${VERSION:-0.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/deis/deis.info b/network/deis/deis.info
new file mode 100644
index 0000000000..2049cb82fd
--- /dev/null
+++ b/network/deis/deis.info
@@ -0,0 +1,10 @@
+PRGNAM="deis"
+VERSION="0.5.0"
+HOMEPAGE="http://deis.io/"
+DOWNLOAD="https://pypi.python.org/packages/source/d/deis/deis-0.5.0.tar.gz"
+MD5SUM="d019c5890a4f108435f015d24b2852fa"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="docopt python-dateutil PyYAML python-requests"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/network/deis/slack-desc b/network/deis/slack-desc
new file mode 100644
index 0000000000..39c0314cbe
--- /dev/null
+++ b/network/deis/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+deis: deis (Command-line Client for Deis)
+deis:
+deis: The Deis client is a Python CLI that issues API calls to a private
+deis: Deis controller, providing a Heroku-inspired PaaS workflow.
+deis:
+deis: Homepage: http://deis.io/
+deis:
+deis:
+deis:
+deis:
+deis: