summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-24 20:07:52 +0100
committer Erik Hanson2014-01-30 06:21:13 +0100
commit1824cac273ae1c2433a1492c31cc2a28da1751da (patch)
treea49f2dec9bbf5c127659baaa1a2250350ce11cd8
parent3cdf884f4302fd9f6786ab55e8f6956b4209f5f9 (diff)
downloadslackbuilds-1824cac273ae1c2433a1492c31cc2a28da1751da.tar.gz
libraries/lunatic-python: Added (bridge between Python and Lua).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/lunatic-python/README4
-rw-r--r--libraries/lunatic-python/lunatic-python.SlackBuild86
-rw-r--r--libraries/lunatic-python/lunatic-python.info10
-rw-r--r--libraries/lunatic-python/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/libraries/lunatic-python/README b/libraries/lunatic-python/README
new file mode 100644
index 0000000000..44a0653e5d
--- /dev/null
+++ b/libraries/lunatic-python/README
@@ -0,0 +1,4 @@
+Lunatic Python is a two-way bridge between Python and Lua, allowing these
+languages to intercommunicate. Being two-way means that it allows Lua inside
+Python, Python inside Lua, Lua inside Python inside Lua, Python inside Lua
+inside Python, and so on.
diff --git a/libraries/lunatic-python/lunatic-python.SlackBuild b/libraries/lunatic-python/lunatic-python.SlackBuild
new file mode 100644
index 0000000000..efd439826c
--- /dev/null
+++ b/libraries/lunatic-python/lunatic-python.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for lunatic-python-bugfix
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=lunatic-python
+SRCNAM=lunatic-python-bugfix
+VERSION=${VERSION:-1.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/lunatic-python.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/lunatic-python.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/lunatic-python-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/lunatic-python/lunatic-python.info b/libraries/lunatic-python/lunatic-python.info
new file mode 100644
index 0000000000..8fffb6a9a1
--- /dev/null
+++ b/libraries/lunatic-python/lunatic-python.info
@@ -0,0 +1,10 @@
+PRGNAM="lunatic-python"
+VERSION="1.1.1"
+HOMEPAGE="http://labix.org/lunatic-python"
+DOWNLOAD="https://pypi.python.org/packages/source/l/lunatic-python-bugfix/lunatic-python-bugfix-1.1.1.tar.gz"
+MD5SUM="42be02430fdd05b657d3a5078bbbe5af"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="lua"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/lunatic-python/slack-desc b/libraries/lunatic-python/slack-desc
new file mode 100644
index 0000000000..f4e84a79e5
--- /dev/null
+++ b/libraries/lunatic-python/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+lunatic-python: lunatic-python (bridge between Python and Lua)
+lunatic-python:
+lunatic-python: Lunatic Python is a two-way bridge between Python and Lua,
+lunatic-python: allowing these languages to intercommunicate. Being two-way means
+lunatic-python: that it allows Lua inside Python, Python inside Lua, Lua inside
+lunatic-python: Python inside Lua, Python inside Lua inside Python, and so on.
+lunatic-python:
+lunatic-python: Homepage: http://labix.org/lunatic-python
+lunatic-python:
+lunatic-python:
+lunatic-python: