summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Erik Falor2013-10-29 08:57:50 +0100
committer Robby Workman2013-10-30 02:12:27 +0100
commit9d18516705d40acacfae3723a573bfcab318b0cb (patch)
tree6b231608add334111c0dfbdc321c9a265baee7ea
parentb6b3de5eac984b3bdbe0886635cd3ea21037cc18 (diff)
downloadslackbuilds-9d18516705d40acacfae3723a573bfcab318b0cb.tar.gz
network/xombrero: Updated for version 1.6.3.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--network/xombrero/Makefile.patch39
-rw-r--r--network/xombrero/xombrero.SlackBuild7
-rw-r--r--network/xombrero/xombrero.h.patch2
-rw-r--r--network/xombrero/xombrero.info7
4 files changed, 29 insertions, 26 deletions
diff --git a/network/xombrero/Makefile.patch b/network/xombrero/Makefile.patch
index b3c7758f3d..3bf61313d7 100644
--- a/network/xombrero/Makefile.patch
+++ b/network/xombrero/Makefile.patch
@@ -1,29 +1,36 @@
---- Makefile 2012-11-28 11:23:15.000000000 -0700
-+++ Makefile.new 2013-02-08 10:21:31.839628119 -0700
-@@ -61,15 +61,21 @@
- install -m 755 -d $(DESTDIR)$(LIBDIR)
+--- Makefile 2013-07-11 11:05:15.000000000 -0600
++++ Makefile.new 2013-09-04 22:10:27.708971431 -0600
+@@ -25,6 +25,7 @@
+ APPDIR?= $(PREFIX)/share/applications
+ MANDIR?= $(PREFIX)/share/man
+ RESDIR?= $(PREFIX)/share/xombrero
++ICODIR?= $(PREFIX)/share/icons/hicolor/apps
+
+ SRCS= $(shell ls ../*.c)
+ SRCS+= linux.c
+@@ -63,15 +64,20 @@
install -m 755 -d $(DESTDIR)$(MANDIR)/man1
install -m 755 -d $(DESTDIR)$(RESDIR)
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/applications
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/16x16
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/32x32
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/48x48
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/64x64
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/128x128
+ install -m 755 -d $(DESTDIR)$(APPDIR)
++ install -m 755 -d $(DESTDIR)$(ICODIR)/16x16
++ install -m 755 -d $(DESTDIR)$(ICODIR)/32x32
++ install -m 755 -d $(DESTDIR)$(ICODIR)/48x48
++ install -m 755 -d $(DESTDIR)$(ICODIR)/64x64
++ install -m 755 -d $(DESTDIR)$(ICODIR)/128x128
install -m 755 xombrero $(DESTDIR)$(BINDIR)
install -m 644 ../xombrero.1 $(DESTDIR)$(MANDIR)/man1/xombrero.1
install -m 644 ../xombrero.css $(DESTDIR)$(RESDIR)
- install -m 644 ../xombrero.desktop $(DESTDIR)$(PREFIX)/share/applications
+ install -m 644 ../xombrero.desktop $(DESTDIR)$(APPDIR)
- install -m 644 ../xombreroicon16.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon32.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon48.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon64.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon128.png $(DESTDIR)$(RESDIR)
-+ install -m 644 ../xombreroicon16.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/16x16/xombrero.png
-+ install -m 644 ../xombreroicon32.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/32x32/xombrero.png
-+ install -m 644 ../xombreroicon48.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/48x48/xombrero.png
-+ install -m 644 ../xombreroicon64.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/64x64/xombrero.png
-+ install -m 644 ../xombreroicon128.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/128x128/xombrero.png
++ install -m 644 ../xombreroicon16.png $(DESTDIR)$(ICODIR)/16x16
++ install -m 644 ../xombreroicon32.png $(DESTDIR)$(ICODIR)/32x32
++ install -m 644 ../xombreroicon48.png $(DESTDIR)$(ICODIR)/48x48
++ install -m 644 ../xombreroicon64.png $(DESTDIR)$(ICODIR)/64x64
++ install -m 644 ../xombreroicon128.png $(DESTDIR)$(ICODIR)/128x128
install -m 644 ../tld-rules $(DESTDIR)$(RESDIR)
install -m 644 ../style.css $(DESTDIR)$(RESDIR)
install -m 644 ../hsts-preload $(DESTDIR)$(RESDIR)
diff --git a/network/xombrero/xombrero.SlackBuild b/network/xombrero/xombrero.SlackBuild
index 93d2e26c92..d06cfd7279 100644
--- a/network/xombrero/xombrero.SlackBuild
+++ b/network/xombrero/xombrero.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=xombrero
-VERSION=${VERSION:-1.4.0}
+VERSION=${VERSION:-1.6.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,7 +71,7 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# patch xombrero.h to not expect resources in /usr/local/share/xombrero
+# Patch xombrero.h to not expect resources in /usr/local/share/xombrero
# https://opensource.conformal.com/flyspray/index.php?do=details&task_id=372
patch -i $CWD/xombrero.h.patch
@@ -93,9 +93,6 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-# Kill a spurrious directory
-rmdir $PKG/usr/lib
-
# Copy the .desktop file into usr/share/applications/,
# massaging its icon property to match our desktop theme
mkdir -p $PKG/usr/share/applications
diff --git a/network/xombrero/xombrero.h.patch b/network/xombrero/xombrero.h.patch
index 14d33b1e0f..f4b20f2772 100644
--- a/network/xombrero/xombrero.h.patch
+++ b/network/xombrero/xombrero.h.patch
@@ -1,6 +1,6 @@
--- xombrero.h 2012-11-28 11:23:15.000000000 -0700
+++ xombrero.h.new 2013-02-08 12:49:32.000610834 -0700
-@@ -688,7 +688,7 @@
+@@ -689,7 +689,7 @@
#define XT_DS_ALLOW_INSECURE_CONTENT (TRUE)
#define XT_DS_ALLOW_INSECURE_SCRIPTS (TRUE)
#define XT_DS_WARN_CERT_CHANGES (0)
diff --git a/network/xombrero/xombrero.info b/network/xombrero/xombrero.info
index a721520eb4..69e4f8ffa5 100644
--- a/network/xombrero/xombrero.info
+++ b/network/xombrero/xombrero.info
@@ -1,11 +1,10 @@
PRGNAM="xombrero"
-VERSION="1.4.0"
+VERSION="1.6.3"
HOMEPAGE="https://opensource.conformal.com/wiki/xombrero"
-DOWNLOAD="https://opensource.conformal.com/snapshots/xombrero/xombrero-1.4.0.tgz"
-MD5SUM="d5431623a7f5ac213adb1bcc0666f593"
+DOWNLOAD="https://opensource.conformal.com/snapshots/xombrero/xombrero-1.6.3.tgz"
+MD5SUM="11248a0f40542265022e8dfe692644da"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libbsd webkitgtk3"
MAINTAINER="Erik Falor"
EMAIL="ewfalor@gmail.com"
-