summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2013-10-28 04:30:24 +0100
committer Robby Workman2013-10-28 05:39:08 +0100
commit6b6f0cae560ca377ff8b60bf70b5cff5232164c4 (patch)
tree533a020dedd8a62f9b1d7f32715fa372eb8c7465
parent49df8a2a48d9387f4d67e583ab3ad5b849bd2f95 (diff)
downloadslackbuilds-6b6f0cae560ca377ff8b60bf70b5cff5232164c4.tar.gz
python/rsa: Added (Pure-Python RSA implementation)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--python/rsa/README5
-rw-r--r--python/rsa/rsa.SlackBuild85
-rw-r--r--python/rsa/rsa.info10
-rw-r--r--python/rsa/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/rsa/README b/python/rsa/README
new file mode 100644
index 0000000000..38bb5d56a7
--- /dev/null
+++ b/python/rsa/README
@@ -0,0 +1,5 @@
+Python-RSA is a pure-Python RSA implementation. It supports encryption and
+decryption, signing and verifying signatures, and key generation according to
+PKCS#1 version 1.5.
+
+Optional dependencies: psyco
diff --git a/python/rsa/rsa.SlackBuild b/python/rsa/rsa.SlackBuild
new file mode 100644
index 0000000000..7e5d980147
--- /dev/null
+++ b/python/rsa/rsa.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for rsa
+
+# Copyright 2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=rsa
+VERSION=${VERSION:-3.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Force the setup.py to use system setuptools. Remove use_setuptools function.
+sed -i '/use_setuptools/d' setup.py
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/rsa/rsa.info b/python/rsa/rsa.info
new file mode 100644
index 0000000000..2c4badc2cb
--- /dev/null
+++ b/python/rsa/rsa.info
@@ -0,0 +1,10 @@
+PRGNAM="rsa"
+VERSION="3.1.1"
+HOMEPAGE="http://stuvel.eu/rsa"
+DOWNLOAD="https://pypi.python.org/packages/source/r/rsa/rsa-3.1.1.tar.gz"
+MD5SUM="01e6b88c078e8f74718a455e0a05623d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools pyasn1"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/rsa/slack-desc b/python/rsa/slack-desc
new file mode 100644
index 0000000000..b300f983fd
--- /dev/null
+++ b/python/rsa/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+rsa: rsa (Pure-Python RSA implementation)
+rsa:
+rsa: Python-RSA is a pure-Python RSA implementation. It supports encryption
+rsa: and decryption, signing and verifying signatures, and key generation
+rsa: according to PKCS#1 version 1.5.
+rsa:
+rsa: Homepage: http://stuvel.eu/rsa
+rsa:
+rsa:
+rsa:
+rsa: