summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Fernando Giannasi2013-10-28 05:09:25 +0100
committer Robby Workman2013-10-28 05:39:09 +0100
commit5b4af2018bff6a69c2816896c89d2306b0dc6459 (patch)
tree4fe08214ebb0f3a92487cac3b2c9a9ffee1de8ee
parent19aed08cc5064ed48619cbf4642b6ee06dd88dcf (diff)
downloadslackbuilds-5b4af2018bff6a69c2816896c89d2306b0dc6459.tar.gz
network/t50: Added (Experimental Mixed Packet Injector Tool)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--network/t50/README9
-rw-r--r--network/t50/slack-desc19
-rw-r--r--network/t50/t50.SlackBuild90
-rw-r--r--network/t50/t50.info11
4 files changed, 129 insertions, 0 deletions
diff --git a/network/t50/README b/network/t50/README
new file mode 100644
index 0000000000..e6e317daaa
--- /dev/null
+++ b/network/t50/README
@@ -0,0 +1,9 @@
+T50 is a tool designed to perform stress testing on a variety of infrastructure
+network devices, covering some regular protocols (ICMP, IGMP, TCP and UDP),
+some infrastructure specific protocols (GRE, IPSec and RSVP) and some routing
+protocols (RIP, EIGRP and OSPF).
+
+The main differentiator of T50 is that it is able to send all protocols
+sequentially using one single SOCKET, and it is capable of being used to
+modify network routes, letting IT Security Professionals perform advanced
+tests.
diff --git a/network/t50/slack-desc b/network/t50/slack-desc
new file mode 100644
index 0000000000..a69f031ffd
--- /dev/null
+++ b/network/t50/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+t50: t50 (Experimental Mixed Packet Injector Tool)
+t50:
+t50: T50 is a tool designed to perform stress testing on a variety of
+t50: infrastructure network devices, covering some regular protocols (ICMP,
+t50: IGMP, TCP and UDP), some infrastructure specific protocols (GRE, IPSec
+t50: and RSVP) and some routing protocols (RIP, EIGRP and OSPF).
+t50:
+t50: Homepage: http://t50.sourceforge.net/
+t50:
+t50:
+t50:
diff --git a/network/t50/t50.SlackBuild b/network/t50/t50.SlackBuild
new file mode 100644
index 0000000000..834c6138fa
--- /dev/null
+++ b/network/t50/t50.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for t50
+
+# Copyright 2013 - Fernando Giannasi - São Paulo - Brasil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=t50
+VERSION=${VERSION:-5.4.1_rc1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCVERS=$(echo $VERSION | tr _ -)
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+
+set -e # Exit on most errors
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVERSION
+tar xvf $CWD/$PRGNAM-$SRCVERS.tgz
+cd $PRGNAM-$SRCVERS
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sed -i "s,-O3,$SLKCFLAGS," src/Makefile
+make -C src all PREFIX=/usr MANDIR=/usr/man/man8
+
+mkdir -p $PKG/usr/sbin $PKG/usr/man/man8
+make -C src install PREFIX=$PKG/usr MANDIR=$PKG/usr/man/man8
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGELOG LICENSE README VERSION $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/t50/t50.info b/network/t50/t50.info
new file mode 100644
index 0000000000..2d63fc1b30
--- /dev/null
+++ b/network/t50/t50.info
@@ -0,0 +1,11 @@
+PRGNAM="t50"
+VERSION="5.4.1_rc1"
+HOMEPAGE="http://t50.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/project/t50/t50-5.4.1/t50-5.4.1-rc1.tgz"
+MD5SUM="26db475b41459e4397f674776caf0f53"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Fernando Giannasi"
+EMAIL="phoemur@gmail.com"
+