summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andre Barboza2013-10-28 15:53:11 +0100
committer Robby Workman2013-10-30 02:12:24 +0100
commitfd672e3c99b4248a3f1b06bd067e5828340e7f96 (patch)
treed22044d4fc8ce0521d06db6b70db57d5e7f84a24
parentbc800d423ac701f922abd560b7400fd022080b49 (diff)
downloadslackbuilds-fd672e3c99b4248a3f1b06bd067e5828340e7f96.tar.gz
development/gplcver: Added (open-source Verilog simulator).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--development/gplcver/README5
-rw-r--r--development/gplcver/files/gplcver-CMakeLists.txt26
-rw-r--r--development/gplcver/files/vcddiff-CMakeLists.txt15
-rw-r--r--development/gplcver/gplcver.SlackBuild97
-rw-r--r--development/gplcver/gplcver.info10
-rw-r--r--development/gplcver/slack-desc18
6 files changed, 171 insertions, 0 deletions
diff --git a/development/gplcver/README b/development/gplcver/README
new file mode 100644
index 0000000000..2e7321c468
--- /dev/null
+++ b/development/gplcver/README
@@ -0,0 +1,5 @@
+Open-source interpreted Verilog simulator with a feature set and
+performance similar to Verilog-XL.
+Implements all IEEE 1364-1995 features along with some Verilog-2001
+features.
+Full support for Verilog PLIs.
diff --git a/development/gplcver/files/gplcver-CMakeLists.txt b/development/gplcver/files/gplcver-CMakeLists.txt
new file mode 100644
index 0000000000..3f5b34d256
--- /dev/null
+++ b/development/gplcver/files/gplcver-CMakeLists.txt
@@ -0,0 +1,26 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(gplcver)
+
+SET(CMAKE_C_FLAGS $ENV{CFLAGS})
+
+SET(BIN_INSTALL_DIR bin)
+SET(DATA_INSTALL_DIR share/gplcver)
+SET(DOC_INSTALL_DIR doc/gplcver)
+SET(MAN_INSTALL_DIR man/man1)
+
+LINK_LIBRARIES(m)
+LINK_LIBRARIES(dl)
+INCLUDE_DIRECTORIES(pli_incs)
+
+SET(gplcver_sources src/cver.c src/dig_main.c src/v_acc.c src/v_cnv.c src/v_dbg.c src/v_dbg2.c src/v_del.c src/v_ex.c src/v_ex2.c src/v_ex3.c src/v_ex4.c src/v_fx.c src/v_fx2.c src/v_fx3.c src/v_ms.c src/v_prp.c src/v_prp2.c src/v_sdf.c src/v_sim.c src/v_src.c src/v_src2.c src/v_src3.c src/v_tf.c src/v_trch.c src/v_vpi.c src/v_vpi2.c src/v_vpi3.c src/veriuser.c src/vpiuser.c)
+
+ADD_EXECUTABLE(cver ${gplcver_sources})
+
+INSTALL(FILES "COPYING" "INSTALL" "LICENSE" "OUR_PHILOSOPHY" "Changelog" "NEW.CVER.2001.RELEASE.NOTES" "README" DESTINATION ${DOC_INSTALL_DIR})
+INSTALL(FILES "doc/cver-extensions.txt" "doc/cver.FAQ" "doc/cver.faq.htm" "doc/cver.hlp" "doc/dbg.hlp" "doc/systasks.pdf" "doc/systasks.ps" DESTINATION ${DOC_INSTALL_DIR})
+INSTALL(DIRECTORY "tests_and_examples/" DESTINATION ${DOC_INSTALL_DIR}/tests_and_examples)
+INSTALL(FILES "doc/systasks.1" DESTINATION ${MAN_INSTALL_DIR})
+INSTALL(TARGETS cver DESTINATION ${BIN_INSTALL_DIR})
+
+ADD_SUBDIRECTORY(vcddiff.dir)
diff --git a/development/gplcver/files/vcddiff-CMakeLists.txt b/development/gplcver/files/vcddiff-CMakeLists.txt
new file mode 100644
index 0000000000..9731b7e9bf
--- /dev/null
+++ b/development/gplcver/files/vcddiff-CMakeLists.txt
@@ -0,0 +1,15 @@
+SET(BIN_INSTALL_DIR bin)
+SET(DATA_INSTALL_DIR share/gplcver)
+SET(DOC_INSTALL_DIR doc/gplcver/vcddiff)
+SET(MAN_INSTALL_DIR man/man1)
+
+LINK_LIBRARIES(m)
+
+SET(vcddiff_sources src/vcddiff.c)
+
+ADD_EXECUTABLE(vcddiff ${vcddiff_sources})
+
+INSTALL(FILES "Changelog" "README.vcddiff" "src/README" DESTINATION ${DOC_INSTALL_DIR})
+INSTALL(DIRECTORY "examples.vcddiff" DESTINATION ${DOC_INSTALL_DIR})
+INSTALL(TARGETS vcddiff DESTINATION ${BIN_INSTALL_DIR})
+
diff --git a/development/gplcver/gplcver.SlackBuild b/development/gplcver/gplcver.SlackBuild
new file mode 100644
index 0000000000..502132a61a
--- /dev/null
+++ b/development/gplcver/gplcver.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/sh
+
+# Slackware build script for GPL CVER
+
+# Copyright 2013 - Andre Barboza - Belo Horizonte, Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=gplcver
+VERSION=${VERSION:-2.12a}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION.src
+tar xvf $CWD/$PRGNAM-$VERSION.src.tar.bz2
+cd $PRGNAM-$VERSION.src
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+cat $CWD/files/gplcver-CMakeLists.txt > CMakeLists.txt
+cat $CWD/files/vcddiff-CMakeLists.txt > vcddiff.dir/CMakeLists.txt
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc
+mv $PKG/usr/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/gplcver/gplcver.info b/development/gplcver/gplcver.info
new file mode 100644
index 0000000000..70954b6e33
--- /dev/null
+++ b/development/gplcver/gplcver.info
@@ -0,0 +1,10 @@
+PRGNAM="gplcver"
+VERSION="2.12a"
+HOMEPAGE="http://sourceforge.net/projects/gplcver/"
+DOWNLOAD="http://downloads.sourceforge.net/gplcver/gplcver-2.12a.src.tar.bz2"
+MD5SUM="857a15a9ebc8ef63ece01502509cbeb7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
diff --git a/development/gplcver/slack-desc b/development/gplcver/slack-desc
new file mode 100644
index 0000000000..200476d2f1
--- /dev/null
+++ b/development/gplcver/slack-desc
@@ -0,0 +1,18 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gplcver: gplcver (open-source Verilog simulator)
+gplcver:
+gplcver: Open-source interpreted Verilog simulator with a feature set and
+gplcver: performance similar to Verilog-XL. Implements all IEEE 1364-1995
+gplcver: features along with some Verilog-2001 features. Full support for
+gplcver: Verilog PLIs.
+gplcver:
+gplcver: homepage: http://sourceforge.net/projects/gplcver/
+gplcver:
+gplcver: