summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Robby Workman2013-10-28 05:57:59 +0100
committer Robby Workman2013-10-28 05:57:59 +0100
commit8c229b6b8cc092b1f9361d7ff7081c76e769af44 (patch)
tree22c37eafc3934311f2bfbb3207518c9c415c6a8a
parent50fdb3ffad8f9d94de3e2d96977ff55b20eb83f6 (diff)
downloadslackbuilds-8c229b6b8cc092b1f9361d7ff7081c76e769af44.tar.gz
audio/python-audiotools: Fixed update (moved from Python category)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--audio/python-audiotools/python-audiotools.SlackBuild2
-rw-r--r--audio/python-audiotools/python-audiotools.info6
-rw-r--r--python/python-audiotools/README12
-rw-r--r--python/python-audiotools/doinst.sh15
-rw-r--r--python/python-audiotools/python-audiotools.SlackBuild94
-rw-r--r--python/python-audiotools/python-audiotools.info10
-rw-r--r--python/python-audiotools/slack-desc19
7 files changed, 4 insertions, 154 deletions
diff --git a/audio/python-audiotools/python-audiotools.SlackBuild b/audio/python-audiotools/python-audiotools.SlackBuild
index 02468e1119..7ff4bfc73d 100644
--- a/audio/python-audiotools/python-audiotools.SlackBuild
+++ b/audio/python-audiotools/python-audiotools.SlackBuild
@@ -26,7 +26,7 @@
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM="python-audiotools"
-VERSION=${VERSION:-2.19}
+VERSION=${VERSION:-2.20}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
diff --git a/audio/python-audiotools/python-audiotools.info b/audio/python-audiotools/python-audiotools.info
index dcb0932696..d0e859fec2 100644
--- a/audio/python-audiotools/python-audiotools.info
+++ b/audio/python-audiotools/python-audiotools.info
@@ -1,8 +1,8 @@
PRGNAM="python-audiotools"
-VERSION="2.19"
+VERSION="2.20"
HOMEPAGE="http://audiotools.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/audiotools/audiotools-2.19.tar.gz"
-MD5SUM="2adab3ff40af45e0f53d52377307c83f"
+DOWNLOAD="http://downloads.sourceforge.net/audiotools/audiotools-2.20.tar.gz"
+MD5SUM="a295105ad23689bdecd3952aa8736302"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/python/python-audiotools/README b/python/python-audiotools/README
deleted file mode 100644
index 710c86e730..0000000000
--- a/python/python-audiotools/README
+++ /dev/null
@@ -1,12 +0,0 @@
-Python Audio Tools are a collection of audio handling programs which work
-from the command line. These include programs for CD extraction, track
-conversion from one audio format to another, track renaming and retagging,
-track identification, CD burning from tracks, and more. It supports
-internationalized track filenames and metadata using Unicode. It works
-with high-definition, multi-channel audio as well as CD-quality. Track
-conversion uses multiple CPUs or CPU cores if available to greatly speed
-the transcoding process. Track metadata can be retrieved from FreeDB or
-FreeDB-compatible servers.
-
-Supported audio formats are WAV, AIFF, Sun AU, FLAC, WavPack, MP3, MP2,
-Ogg Vorbis, Ogg Speex, Ogg FLAC, and M4A.
diff --git a/python/python-audiotools/doinst.sh b/python/python-audiotools/doinst.sh
deleted file mode 100644
index ee19f823a3..0000000000
--- a/python/python-audiotools/doinst.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-config etc/audiotools.cfg.new
-
diff --git a/python/python-audiotools/python-audiotools.SlackBuild b/python/python-audiotools/python-audiotools.SlackBuild
deleted file mode 100644
index 7ff4bfc73d..0000000000
--- a/python/python-audiotools/python-audiotools.SlackBuild
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Python Audio Tools
-# Home Page: http://audiotools.sourceforge.net/
-
-# Copyright (c) 2010-2013, Nishant Limbachia, Hoffman Estates, IL, USA
-# <nishant _AT_ mnspace _DOT_ net>
-# All rights reserved.
-
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-
-# 1. Redistributions of script must retain the above copyright notice,
-# this list of conditions and the following disclaimer.
-
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
-# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
-# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
-# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
-# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
-# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM="python-audiotools"
-VERSION=${VERSION:-2.20}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM="$(printf $PRGNAM | cut -f2 -d-)"
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG $TMP/$SRCNAM-$VERSION
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/man/man{1,5}
-( cd docs; make install MAN_PATH=$PKG/usr/man )
-
-mv $PKG/etc/audiotools.cfg $PKG/etc/audiotools.cfg.new
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING INSTALL TODO $PKG/usr/doc/$PRGNAM-$VERSION
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-audiotools/python-audiotools.info b/python/python-audiotools/python-audiotools.info
deleted file mode 100644
index d0e859fec2..0000000000
--- a/python/python-audiotools/python-audiotools.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-audiotools"
-VERSION="2.20"
-HOMEPAGE="http://audiotools.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/audiotools/audiotools-2.20.tar.gz"
-MD5SUM="a295105ad23689bdecd3952aa8736302"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Nishant Limbachia"
-EMAIL="nishant@mnspace.net"
diff --git a/python/python-audiotools/slack-desc b/python/python-audiotools/slack-desc
deleted file mode 100644
index 3fb94f270a..0000000000
--- a/python/python-audiotools/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-python-audiotools: python-audiotools (collection of audio handling programs)
-python-audiotools:
-python-audiotools: Python Audio Tools are a collection of audio handling programs
-python-audiotools: which work from the command line. These include programs for
-python-audiotools: CD extraction, track conversion from one audio format to another,
-python-audiotools: track renaming and retagging, track identification, CD burning
-python-audiotools: from tracks, and more.
-python-audiotools:
-python-audiotools: Homepage: http://audiotools.sourceforge.net/
-python-audiotools:
-python-audiotools: