summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2013-04-10 18:34:16 +0200
committer Robby Workman2013-04-16 00:21:01 +0200
commit6ce215668f59bf476d4d0a22eb88f4e357382023 (patch)
tree0ebb52abba6b2671c3875f04fc25fc17136e2968
parent8fb81a141d9329fc2655e7580e8306f36759bfcc (diff)
downloadslackbuilds-6ce215668f59bf476d4d0a22eb88f4e357382023.tar.gz
development/squeak-vm: Added (Smalltalk compatible VM)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--development/squeak-vm/README8
-rw-r--r--development/squeak-vm/slack-desc19
-rw-r--r--development/squeak-vm/squeak-vm.SlackBuild119
-rw-r--r--development/squeak-vm/squeak-vm.info10
4 files changed, 156 insertions, 0 deletions
diff --git a/development/squeak-vm/README b/development/squeak-vm/README
new file mode 100644
index 0000000000..93fb84a5cb
--- /dev/null
+++ b/development/squeak-vm/README
@@ -0,0 +1,8 @@
+Squeak is a full-featured implementation of the Smalltalk
+programming language and environment based on the original
+Smalltalk-80 system.
+
+Squeak has very powerful 2- and 3-D graphics, sound, video, MIDI,
+animation and other multimedia capabilities.
+
+Optional dependency: speex, pulseAudio
diff --git a/development/squeak-vm/slack-desc b/development/squeak-vm/slack-desc
new file mode 100644
index 0000000000..208ff19e78
--- /dev/null
+++ b/development/squeak-vm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler-------------------------------------------------------------|
+squeak-vm: squeak-vm (squeak virtual machine)
+squeak-vm:
+squeak-vm: Squeak is a full-featured implementation of the Smalltalk
+squeak-vm: programming language and environment based on the original
+squeak-vm: Smalltalk-80 system.
+squeak-vm:
+squeak-vm: Squeak has very powerful 2- and 3-D graphics, sound, video, MIDI,
+squeak-vm: animation and other multimedia capabilities.
+squeak-vm:
+squeak-vm: Project Site: http://squeakvm.org/index.html
+squeak-vm:
diff --git a/development/squeak-vm/squeak-vm.SlackBuild b/development/squeak-vm/squeak-vm.SlackBuild
new file mode 100644
index 0000000000..3f9b03f6c6
--- /dev/null
+++ b/development/squeak-vm/squeak-vm.SlackBuild
@@ -0,0 +1,119 @@
+#!/bin/sh
+
+# Slackware build script for squeak-vm
+
+# Copyright 2013 Willy Sudiarto Raharjo <willysr@slackware-id.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=squeak-vm
+SRCNAM=Squeak
+VERSION=${VERSION:-4.10.2.2614}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION-src
+tar xvf $CWD/$SRCNAM-$VERSION-src.tar.gz
+cd $SRCNAM-$VERSION-src
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix location of libraries (as --libdir does not work)
+for f in CMakeLists.txt cmake/squeak.in cmake/squeak.sh.in; do
+ sed \
+ -e "s/lib\/squeak/lib${LIBDIRSUFFIX}\/squeak/g" \
+ -i unix/$f
+done
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ ../unix/cmake/configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-mpg-mmx \
+ --without-SUGAR \
+ --build=$ARCH-slackware-linux
+
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+mkdir -p $PKG/usr/man
+mv $PKG/usr/share/man/* $PKG/usr/man/
+rm -rf $PKG/usr/share/
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ unix/ChangeLog unix/README* unix/doc/COPYING unix/doc/COPYRIGHT unix/doc/LICENSE \
+ unix/doc/README* unix/doc/HowTo* unix/doc/*RELEASE_NOTES \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/squeak-vm/squeak-vm.info b/development/squeak-vm/squeak-vm.info
new file mode 100644
index 0000000000..143ca4bac6
--- /dev/null
+++ b/development/squeak-vm/squeak-vm.info
@@ -0,0 +1,10 @@
+PRGNAM="squeak-vm"
+VERSION="4.10.2.2614"
+HOMEPAGE="http://squeakvm.org/"
+DOWNLOAD="http://squeakvm.org/unix/release/Squeak-4.10.2.2614-src.tar.gz"
+MD5SUM="8a5cb1d6899d55df56154fab8716e034"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Willy Sudiarto Raharjo"
+EMAIL="willysr@slackware-id.org" \ No newline at end of file