summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author James Geboski2012-12-03 01:55:27 +0100
committer dsomero2012-12-11 22:21:55 +0100
commitc6c47fa4dcc1f75cc166beb1a94e55cbb69a0fcb (patch)
tree271cce0b4e766aa956f3eb47d70ae5a8a5b26ec8
parent1f8f64977eec47846bafc69eb1f907da6fba3b05 (diff)
downloadslackbuilds-c6c47fa4dcc1f75cc166beb1a94e55cbb69a0fcb.tar.gz
libraries/genshi: Changed REQUIRES to distribute
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--libraries/genshi/README6
-rw-r--r--libraries/genshi/genshi.SlackBuild18
-rw-r--r--libraries/genshi/genshi.info6
-rw-r--r--libraries/genshi/slack-desc6
4 files changed, 14 insertions, 22 deletions
diff --git a/libraries/genshi/README b/libraries/genshi/README
index 7fc8951fc1..c5bd6c9d0d 100644
--- a/libraries/genshi/README
+++ b/libraries/genshi/README
@@ -1,3 +1,3 @@
-Genshi is a Python library that provides an integrated set of
-components for parsing, generating, and processing HTML, XML
-or other textual content for output generation on the web
+Genshi is a Python library that provides an integrated set of
+components for parsing, generating, and processing HTML, XML,
+or other textual content for output generation on the web.
diff --git a/libraries/genshi/genshi.SlackBuild b/libraries/genshi/genshi.SlackBuild
index 6d03e9319e..9139a006df 100644
--- a/libraries/genshi/genshi.SlackBuild
+++ b/libraries/genshi/genshi.SlackBuild
@@ -1,21 +1,19 @@
#!/bin/sh
-# Slackware build script for
-
+# Slackware build script for Genshi
# Written by Eugene Suter <easuter at gmail.com>
+# Maintained by James Geboski <jgeboski@gmail.com>
PRGNAM="genshi"
SRCNAM="Genshi"
VERSION=${VERSION:-0.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -39,7 +37,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e # Exit on most errors
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -54,21 +52,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Using the "install" option of the python setup script will build and
-# install the files directly into $PKG
python setup.py install --root=$PKG
-# Documentation
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv doc/* $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/* COPYING ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-# Copy the slack-desc
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-# Make the package
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/genshi/genshi.info b/libraries/genshi/genshi.info
index 73f5d7fc57..c238d31dd5 100644
--- a/libraries/genshi/genshi.info
+++ b/libraries/genshi/genshi.info
@@ -5,6 +5,6 @@ DOWNLOAD="http://ftp.edgewall.com/pub/genshi/Genshi-0.6.tar.gz"
MD5SUM="604e8b23b4697655d36a69c2d8ef7187"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pysetuptools"
-MAINTAINER="Eugene Suter"
-EMAIL="easuter@gmail.com"
+REQUIRES="distribute"
+MAINTAINER="James Geboski"
+EMAIL="jgeboski@gmail.com"
diff --git a/libraries/genshi/slack-desc b/libraries/genshi/slack-desc
index eb6b102151..6fff3c7516 100644
--- a/libraries/genshi/slack-desc
+++ b/libraries/genshi/slack-desc
@@ -8,9 +8,9 @@
|-----handy-ruler------------------------------------------------------|
genshi: Genshi (Python toolkit for generation of output for the web)
genshi:
-genshi: Genshi is a Python library that provides an integrated set of
-genshi: components for parsing, generating, and processing HTML, XML
-genshi: or other textual content for output generation on the web
+genshi: Genshi is a Python library that provides an integrated set of
+genshi: components for parsing, generating, and processing HTML, XML,
+genshi: or other textual content for output generation on the web.
genshi:
genshi: Homepage: http://genshi.edgewall.org/
genshi: