summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author John Berger2012-12-11 11:50:07 +0100
committer dsomero2012-12-11 22:23:07 +0100
commit579e9eb0d19694fa243d437b2c0fda0854c46e6a (patch)
treec9a275dc968616ea61a803b483fc3e74373c4172
parentfba8e23adeeb776dfc4a09eb272da3268df5353a (diff)
downloadslackbuilds-579e9eb0d19694fa243d437b2c0fda0854c46e6a.tar.gz
network/dillo: Updated for version 3.0.2.
Now depends on fltk13 (not fltk2 anymore) Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--network/dillo/README7
-rw-r--r--network/dillo/dillo.SlackBuild33
-rw-r--r--network/dillo/dillo.info12
-rw-r--r--network/dillo/slack-desc8
4 files changed, 44 insertions, 16 deletions
diff --git a/network/dillo/README b/network/dillo/README
index 1513520974..dcf1edfa48 100644
--- a/network/dillo/README
+++ b/network/dillo/README
@@ -1,2 +1,7 @@
Dillo is a multi-platform graphical web browser known for its speed
-and small footprint. It is written in C and C++ and is based on FLTK2.
+and small footprint. It is written in C and C++ and is based on FLTK.
+
+HTTPS and SSL support is built into this but is only at *alpha* stage. It can
+be commented out in the dillo.SlackBuild file if you wish.
+
+The homepage of FLTK is http://www.fltk.org/
diff --git a/network/dillo/dillo.SlackBuild b/network/dillo/dillo.SlackBuild
index 58d98dbcef..f005cb24c5 100644
--- a/network/dillo/dillo.SlackBuild
+++ b/network/dillo/dillo.SlackBuild
@@ -1,12 +1,29 @@
#!/bin/sh
-# Slackware build script for dillo. It has NOT been tested on x86_64.
+# Slackware build script for dillo.
-# Maintainer: Mikhail Zotov
-# Public domain
+# Copyright 2012 John Berger <insomniactoo@localnet.com>, TN, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=dillo
-VERSION=${VERSION:-2.2.1}
+VERSION=${VERSION:-3.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -52,11 +69,17 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+sed -i 's/fltk-config/fltk13-config/g' configure.in
+autoreconf
+
+ #https and ssl are in the alpha stage, but if you don't want to try and use it
+ #just delete or comment out --enable-ssl
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
+ --enable-ssl \
--prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --libdir=/usr/lib${LIBDIRSUFFIX}/fltk13 \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
diff --git a/network/dillo/dillo.info b/network/dillo/dillo.info
index 1f751cf3af..39ef789c5a 100644
--- a/network/dillo/dillo.info
+++ b/network/dillo/dillo.info
@@ -1,10 +1,10 @@
PRGNAM="dillo"
-VERSION="2.2.1"
+VERSION="3.0.2"
HOMEPAGE="http://www.dillo.org/"
-DOWNLOAD="http://www.dillo.org/download/dillo-2.2.1.tar.bz2"
-MD5SUM="8875d0188b9281fa2dd683220dcf58a8"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/dillo-3.0.2.tar.bz2"
+MD5SUM="81b82112cefcc7d54fe2972a21f42930"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="fltk2"
-MAINTAINER="Mikhail Zotov"
-EMAIL="mikhail dot ru at gmail dot com"
+REQUIRES="fltk13"
+MAINTAINER="John Berger"
+EMAIL="insomniactoo@localnet.com"
diff --git a/network/dillo/slack-desc b/network/dillo/slack-desc
index cce3f54860..154a7e7a26 100644
--- a/network/dillo/slack-desc
+++ b/network/dillo/slack-desc
@@ -8,10 +8,10 @@
|-----handy-ruler------------------------------------------------------|
dillo: dillo (dillo web browser)
dillo:
-dillo: Dillo is a multi-platform graphical web browser known for its speed
-dillo: and small footprint. It is written in C and C++ and is based on
-dillo: FLTK2. Dillo is free software made available under the terms of the
-dillo: GNU GPLv3.
+dillo: Dillo is a multi-platform graphical web browser known
+dillo: for its speed and small footprint. It is written in C and
+dillo: C++ and is based on FLTK. Dillo is free software made
+dillo: available under the terms of the GNU GPLv3.
dillo:
dillo: Homepage: http://www.dillo.org
dillo: