summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Rowland2012-02-19 19:16:10 +0100
committer Robby Workman2012-02-20 19:20:30 +0100
commit1d8c21adb98fa929cf47c08c6e01f2e735c3f066 (patch)
tree306eb414abe8262f5f3da064bae6901d4eb3f7bc
parentc8afc0b8202b57130759d49a560e2d842316b225 (diff)
downloadslackbuilds-1d8c21adb98fa929cf47c08c6e01f2e735c3f066.tar.gz
desktop/obapps: Added (a graphical tool for configuring per-application settings)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
-rw-r--r--desktop/obapps/README4
-rw-r--r--desktop/obapps/obapps.SlackBuild69
-rw-r--r--desktop/obapps/obapps.info10
-rw-r--r--desktop/obapps/slack-desc19
4 files changed, 102 insertions, 0 deletions
diff --git a/desktop/obapps/README b/desktop/obapps/README
new file mode 100644
index 0000000000..1cf1360584
--- /dev/null
+++ b/desktop/obapps/README
@@ -0,0 +1,4 @@
+OBApps is a graphical too for configuring the per-application
+settings (window matching) in the Openbox window manager.
+
+OBApps requires wxPython and python-xlib.
diff --git a/desktop/obapps/obapps.SlackBuild b/desktop/obapps/obapps.SlackBuild
new file mode 100644
index 0000000000..6411cca09e
--- /dev/null
+++ b/desktop/obapps/obapps.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for obapps
+
+# Written by Andrew Rowland <darowland@iee.org>
+
+PRGNAM=obapps
+VERSION=${VERSION:-0.1.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/obapps/obapps.info b/desktop/obapps/obapps.info
new file mode 100644
index 0000000000..f14eb818ac
--- /dev/null
+++ b/desktop/obapps/obapps.info
@@ -0,0 +1,10 @@
+PRGNAM="obapps"
+VERSION="0.1.7"
+HOMEPAGE="http://sourceforge.net/apps/mediawiki/obapps/"
+DOWNLOAD="http://downloads.sourceforge.net/project/obapps/obapps-0.1.7.tar.gz"
+MD5SUM="de9fcc8430faa3ebeeaa4d4abf7aae17"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Andrew Rowland"
+EMAIL="darowland@ieee.org"
+APPROVED="Erik Hanson"
diff --git a/desktop/obapps/slack-desc b/desktop/obapps/slack-desc
new file mode 100644
index 0000000000..d961f79cea
--- /dev/null
+++ b/desktop/obapps/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler----------------------------------------------------|
+obapps: obapps (a graphical tool for configuring per-application settings)
+obapps:
+obapps: OBApps is a graphical too for configuring the per-application
+obapps: settings (window matching) in the Openbox window manager.
+obapps:
+obapps:
+obapps:
+obapps:
+obapps:
+obapps: http://sourceforge.net/apps/mediawiki/obapps/
+obapps: