summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author David Somero2011-12-25 16:13:30 +0100
committer Robby Workman2011-12-27 17:15:07 +0100
commitfadef2b83e3ec3d688159a6896d7153d23457a5f (patch)
treea94a1209c66e7a58794e64cd55dbf14af7763f0b
parent6c9765592f1daf4b51d8669c439cc60915b3d413 (diff)
downloadslackbuilds-fadef2b83e3ec3d688159a6896d7153d23457a5f.tar.gz
python/python-oauth2: Added (OAuth clients and servers)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--python/python-oauth2/README3
-rw-r--r--python/python-oauth2/python-oauth2.SlackBuild85
-rw-r--r--python/python-oauth2/python-oauth2.info10
-rw-r--r--python/python-oauth2/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/python-oauth2/README b/python/python-oauth2/README
new file mode 100644
index 0000000000..e7bbe7a08f
--- /dev/null
+++ b/python/python-oauth2/README
@@ -0,0 +1,3 @@
+A fully tested, abstract interface to creating OAuth clients and servers.
+
+Requires: urlgrabber.
diff --git a/python/python-oauth2/python-oauth2.SlackBuild b/python/python-oauth2/python-oauth2.SlackBuild
new file mode 100644
index 0000000000..87c255ecdc
--- /dev/null
+++ b/python/python-oauth2/python-oauth2.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for python-oauth2
+# Copyright 2011 David Somero <dsomero@hotmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-oauth2
+VERSION=${VERSION:-1.5.211}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=oauth2
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-oauth2/python-oauth2.info b/python/python-oauth2/python-oauth2.info
new file mode 100644
index 0000000000..13d7d29187
--- /dev/null
+++ b/python/python-oauth2/python-oauth2.info
@@ -0,0 +1,10 @@
+PRGNAM="python-oauth2"
+VERSION="1.5.211"
+HOMEPAGE="http://pypi.python.org/pypi/oauth2/"
+DOWNLOAD="http://pypi.python.org/packages/source/o/oauth2/oauth2-1.5.211.tar.gz"
+MD5SUM="987ad7365a70e2286bd1cebb344debbc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="David Somero"
+EMAIL="dsomero@hotmail.com"
+APPROVED="Niels Horn"
diff --git a/python/python-oauth2/slack-desc b/python/python-oauth2/slack-desc
new file mode 100644
index 0000000000..b566ec4cf5
--- /dev/null
+++ b/python/python-oauth2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-oauth2: python-oauth2 (OAuth clients and servers)
+python-oauth2:
+python-oauth2: A fully tested, abstract interface to creating OAuth clients and
+python-oauth2: servers.
+python-oauth2:
+python-oauth2:
+python-oauth2:
+python-oauth2:
+python-oauth2:
+python-oauth2:
+python-oauth2: