summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Niels Horn2011-09-23 22:49:14 +0200
committer Niels Horn2011-09-23 22:52:01 +0200
commitf4f294e2a9af86a5b2df0914a1add062b4284428 (patch)
tree2beaddaa5cac1193331e2912e9a8aea8fac8f224
parent61e64e3e069f84a51c3b4ba184bee98d8fbcda31 (diff)
downloadslackbuilds-f4f294e2a9af86a5b2df0914a1add062b4284428.tar.gz
python/pygoogle: Removed (no longer functional)
See http://pygoogle.sourceforge.net/ for official statement from upstream, declaring the project dead due to incompatibility with Google. Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--python/pygoogle/README5
-rw-r--r--python/pygoogle/pygoogle.SlackBuild81
-rw-r--r--python/pygoogle/pygoogle.info10
-rw-r--r--python/pygoogle/slack-desc19
-rw-r--r--python/pygoogle/version.patch12
5 files changed, 0 insertions, 127 deletions
diff --git a/python/pygoogle/README b/python/pygoogle/README
deleted file mode 100644
index 5934af36fa..0000000000
--- a/python/pygoogle/README
+++ /dev/null
@@ -1,5 +0,0 @@
-This module is a wrapper for the Google Web APIs. It allows you to do Google
-searches, retrieve pages from the Google cache, and ask Google for spelling
-suggestions.
-
-It requires SOAPpy, which is avalaible at SlackBuilds.org.
diff --git a/python/pygoogle/pygoogle.SlackBuild b/python/pygoogle/pygoogle.SlackBuild
deleted file mode 100644
index e10b8ce5f7..0000000000
--- a/python/pygoogle/pygoogle.SlackBuild
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for PyGoogle.
-#
-# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pygoogle
-VERSION=0.6
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="readme.txt doc"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-# fix README permissions (755)
-chmod 644 readme.txt
-
-# Fix version in setup.py
-patch -p1 < $CWD/version.patch
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pygoogle/pygoogle.info b/python/pygoogle/pygoogle.info
deleted file mode 100644
index cce55a6c38..0000000000
--- a/python/pygoogle/pygoogle.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pygoogle"
-VERSION="0.6"
-HOMEPAGE="http://pygoogle.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/pygoogle/pygoogle-0.6.tar.gz"
-MD5SUM="334e2d9e5a765ffa9769e2c4cdfcd110"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Marco Bonetti"
-EMAIL="sid77@slackware.it"
-APPROVED="dsomero"
diff --git a/python/pygoogle/slack-desc b/python/pygoogle/slack-desc
deleted file mode 100644
index 235c3da80a..0000000000
--- a/python/pygoogle/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pygoogle: pygoogle (Python Interface to the Google API)
-pygoogle:
-pygoogle: A Python Interface to the Google API.
-pygoogle:
-pygoogle:
-pygoogle:
-pygoogle:
-pygoogle:
-pygoogle:
-pygoogle:
-pygoogle:
diff --git a/python/pygoogle/version.patch b/python/pygoogle/version.patch
deleted file mode 100644
index add7c6b47d..0000000000
--- a/python/pygoogle/version.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur pygoogle-0.6.orig/setup.py pygoogle-0.6/setup.py
---- pygoogle-0.6.orig/setup.py 2004-02-26 00:54:23.000000000 +0100
-+++ pygoogle-0.6/setup.py 2009-03-13 14:37:38.000000000 +0100
-@@ -3,7 +3,7 @@
- import os
-
- setup (name = "pygoogle",
-- version = "0.5",
-+ version = "0.6",
- description= "Simple interface to Google",
- long_description = "This module lets you search the Google search engine programmatically. See http://www.google.com/apis/ for details." ,
- author = 'Brian Landers (origianlly by Mark Pilgrim and contributors)',