summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author ponce2011-03-05 10:32:57 +0100
committer Niels Horn2011-03-05 10:32:57 +0100
commit915d5559e0cf5fbe29557b9b63a84f77ee2144a5 (patch)
tree092525273f4791605da7ad72aa03ea9774911178
parentd2ec2b6968a02e2dd16474d7681f459f827af7ba (diff)
downloadslackbuilds-915d5559e0cf5fbe29557b9b63a84f77ee2144a5.tar.gz
audio/audacity: Patched for portaudio + new ffmpeg switch.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--audio/audacity/README5
-rw-r--r--audio/audacity/audacity-src-1.3.12-beta-configure-portmixer.patch88
-rw-r--r--audio/audacity/audacity.SlackBuild15
-rw-r--r--audio/audacity/audacity.info6
4 files changed, 107 insertions, 7 deletions
diff --git a/audio/audacity/README b/audio/audacity/README
index 4a0b020133..345d1ed22c 100644
--- a/audio/audacity/README
+++ b/audio/audacity/README
@@ -5,6 +5,5 @@ digital recordings, edit Ogg, MP3, and WAV sound files, and much more.
Audacity requires libsndfile and either wxPython or wxGTK, and optional
dependencies are ffmpeg, soundtouch, and twolame.
-audacity will be built with support for ffmpeg if it is installed, while
-soundtouch and/or twolame support can be enabled in the build script if
-installed. See the build script itself for more information.
+soundtouch, twolame and ffmpeg support can be enabled in the build
+script if installed. See the build script itself for more information.
diff --git a/audio/audacity/audacity-src-1.3.12-beta-configure-portmixer.patch b/audio/audacity/audacity-src-1.3.12-beta-configure-portmixer.patch
new file mode 100644
index 0000000000..8d97ac300f
--- /dev/null
+++ b/audio/audacity/audacity-src-1.3.12-beta-configure-portmixer.patch
@@ -0,0 +1,88 @@
+diff -Naur audacity-src-1.3.12-beta.orig/lib-src/portmixer/configure.ac audacity-src-1.3.12-beta/lib-src/portmixer/configure.ac
+--- audacity-src-1.3.12-beta.orig/lib-src/portmixer/configure.ac 2010-03-30 13:29:47.000000000 +0200
++++ audacity-src-1.3.12-beta/lib-src/portmixer/configure.ac 2011-02-10 11:24:20.256414598 +0100
+@@ -49,29 +49,52 @@
+ fi
+
+ #
++# Check which APIs are available
++#
++
++have_oss=no
++AC_CHECK_HEADERS([sys/soundcard.h linux/soundcard.h machine/soundcard.h], have_oss=yes)
++
++AC_CHECK_HEADER(alsa/asoundlib.h, have_alsa=yes, have_alsa=no)
++AC_CHECK_HEADER(CoreAudio/CoreAudio.h, have_coreaudio=yes, have_coreaudio=no)
++AC_CHECK_HEADER(windows.h, have_windows=yes, have_windows=no)
++
+ # Make sure the support is there
+ #
+ have_support=yes
+-AC_EGREP_HEADER([PaWinDS_GetStreamInputGUID], [pa_win_ds.h], , [have_support=no])
+-if [[ $have_support = "no" ]] ; then
+- AC_MSG_WARN("Missing support in pa_win_ds.h");
+-fi
+-AC_EGREP_HEADER([PaAlsa_GetStreamInputCard], [pa_linux_alsa.h], , [have_support=no])
+-if [[ $have_support = "no" ]] ; then
++
++if [[ $have_alsa = "yes" ]] ; then
++ AC_EGREP_HEADER([PaAlsa_GetStreamInputCard], [pa_linux_alsa.h], , [have_support=no])
++ if [[ $have_support = "no" ]] ; then
+ AC_MSG_WARN("Missing support in pa_linux_alsa.h");
++ fi
+ fi
+-AC_EGREP_HEADER([PaWinMME_GetStreamInputHandle], [pa_win_wmme.h], , [have_support=no])
+-if [[ $have_support = "no" ]] ; then
+- AC_MSG_WARN("Missing support in pa_win_wmme.h");
+-fi
+-AC_EGREP_HEADER([PaMacCore_GetStreamInputDevice], [pa_mac_core.h], , [have_support=no])
+-if [[ $have_support = "no" ]] ; then
++
++if [[ $have_coreaudio = "yes" ]] ; then
++ AC_EGREP_HEADER([PaMacCore_GetStreamInputDevice], [pa_mac_core.h], , [have_support=no])
++ if [[ $have_support = "no" ]] ; then
+ AC_MSG_WARN("Missing support in pa_mac_core.h");
++ fi
+ fi
+-AC_EGREP_HEADER([PaOSS_GetStreamInputDevice], [pa_unix_oss.h], , [have_support=no])
+-if [[ $have_support = "no" ]] ; then
+- AC_MSG_WARN("Missing support in pa_unix_oss.h");
++
++if [[ $have_oss = "yes" ]] ; then
++ AC_EGREP_HEADER([PaOSS_GetStreamInputDevice], [pa_unix_oss.h], , [have_support=no])
++ if [[ $have_support = "no" ]] ; then
++ AC_MSG_WARN("Missing support in pa_unix_oss.h");
++ fi
++fi
++
++if [[ $have_windows = "yes" ]] ; then
++ AC_EGREP_HEADER([PaWinDS_GetStreamInputGUID], [pa_win_ds.h], , [have_support=no])
++ if [[ $have_support = "no" ]] ; then
++ AC_MSG_WARN("Missing support in pa_win_ds.h");
++ fi
++ AC_EGREP_HEADER([PaWinMME_GetStreamInputHandle], [pa_win_wmme.h], , [have_support=no])
++ if [[ $have_support = "no" ]] ; then
++ AC_MSG_WARN("Missing support in pa_win_wmme.h");
++ fi
+ fi
++
+ AC_EGREP_HEADER([Pa_GetStreamHostApiType], [portaudio.h], , [have_support=no])
+ if [[ $have_support = "no" ]] ; then
+ AC_MSG_WARN("Missing support in portaudio.h");
+@@ -88,16 +111,6 @@
+ AC_SUBST( objects, [px_mixer.o] )
+
+ #
+-# Check which APIs are available
+-#
+-
+-have_oss=no
+-AC_CHECK_HEADERS([sys/soundcard.h linux/soundcard.h machine/soundcard.h], have_oss=yes)
+-
+-AC_CHECK_HEADER(alsa/asoundlib.h, have_alsa=yes, have_alsa=no)
+-AC_CHECK_HEADER(CoreAudio/CoreAudio.h, have_coreaudio=yes, have_coreaudio=no)
+-
+-#
+ # Set up to use the identified ones
+ #
+ AC_MSG_NOTICE(---------------------------------------);
diff --git a/audio/audacity/audacity.SlackBuild b/audio/audacity/audacity.SlackBuild
index 0f8a11378c..c4667546cd 100644
--- a/audio/audacity/audacity.SlackBuild
+++ b/audio/audacity/audacity.SlackBuild
@@ -30,7 +30,7 @@
PRGNAM=audacity
VERSION=1.3.12
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -58,6 +58,12 @@ else
do_twolame="with"
fi
+if [ "${FFMPEG:-no}" = "no" ]; then
+ do_ffmpeg="without"
+else
+ do_ffmpeg="with"
+fi
+
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -90,6 +96,12 @@ find . \
# Fix ffmpeg support for version 0.6
patch -p1 -i $CWD/audacity-src-1.3.12-beta-avformat-api-change.patch
+# Fix configure in lib-src/portmixer/
+patch -p1 -i $CWD/audacity-src-1.3.12-beta-configure-portmixer.patch
+cd lib-src/portmixer
+autoreconf
+cd -
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -105,6 +117,7 @@ CXXFLAGS="$SLKCFLAGS" \
--with-libsndfile \
--with-libid3tag \
--with-libresample \
+ --$do_ffmpeg-ffmpeg \
--$do_soundtouch-soundtouch \
--$do_twolame-libtwolame
diff --git a/audio/audacity/audacity.info b/audio/audacity/audacity.info
index f2b89e742e..0b0e76008d 100644
--- a/audio/audacity/audacity.info
+++ b/audio/audacity/audacity.info
@@ -5,6 +5,6 @@ DOWNLOAD="http://audacity.googlecode.com/files/audacity-minsrc-1.3.12-beta.tar.b
MD5SUM="76996fec67181ca82ba191e012518b57"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="Chess Griffin"
-EMAIL="chess@chessgriffin.com"
-APPROVED="rworkman"
+MAINTAINER="ponce"
+EMAIL="matteo.bernardini@gmail.com"
+APPROVED="Niels Horn"