summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author John Tyree2011-03-05 23:00:29 +0100
committer Niels Horn2011-03-05 23:00:29 +0100
commitc463dd63793524e6206cc84f61d30b9982e6040b (patch)
tree42fcc6c45abbd18632b007ff7288c655e501225c
parentba84558aea018023be37f62908e44852063e0bad (diff)
downloadslackbuilds-c463dd63793524e6206cc84f61d30b9982e6040b.tar.gz
libraries/python-bigfloat: Added (floating point arithmetic library)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--libraries/python-bigfloat/README16
-rw-r--r--libraries/python-bigfloat/doinst.sh3
-rw-r--r--libraries/python-bigfloat/python-bigfloat.SlackBuild73
-rw-r--r--libraries/python-bigfloat/python-bigfloat.info10
-rw-r--r--libraries/python-bigfloat/slack-desc20
5 files changed, 122 insertions, 0 deletions
diff --git a/libraries/python-bigfloat/README b/libraries/python-bigfloat/README
new file mode 100644
index 0000000000..a66784f717
--- /dev/null
+++ b/libraries/python-bigfloat/README
@@ -0,0 +1,16 @@
+The bigfloat module is a Python wrapper for the MPFR library for arbitrary
+precision floating-point reliable arithmetic.
+
+The MPFR library is a well-known portable C library for arbitrary-precision
+arithmetic on floating-point numbers. It provides precise control over
+precisions and rounding modes and gives correctly-rounded reproducible
+platform-independent results.
+
+The bigfloat module aims to provide a convenient and friendly Python
+interface to the operations and functions provided by the MPFR library. The
+main class, BigFloat, gives an immutable multiple-precision floating-point
+type that can be freely mixed with Python integers and floats. The Context
+class, when used in conjunction with Pythons with statement, gives a simple
+way of controlling precisions and rounding modes. Additional module-level
+functions provide various standard mathematical operations. There is full
+support for IEEE 754 signed zeros, nans, infinities and subnormals.
diff --git a/libraries/python-bigfloat/doinst.sh b/libraries/python-bigfloat/doinst.sh
new file mode 100644
index 0000000000..c9ae7e166c
--- /dev/null
+++ b/libraries/python-bigfloat/doinst.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+python -m bigfloat.test.test_bigfloat
diff --git a/libraries/python-bigfloat/python-bigfloat.SlackBuild b/libraries/python-bigfloat/python-bigfloat.SlackBuild
new file mode 100644
index 0000000000..d509011a3e
--- /dev/null
+++ b/libraries/python-bigfloat/python-bigfloat.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for python-bigfloat
+
+# Written by John Tyree <johntyree@gmail.com>
+
+PRGNAM=python-bigfloat
+VERSION=${VERSION:-0.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=$(echo $PRGNAM | cut -d- -f2)
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+mv $SRCNAM-$VERSION $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README PKG-INFO CHANGELOG \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-bigfloat/python-bigfloat.info b/libraries/python-bigfloat/python-bigfloat.info
new file mode 100644
index 0000000000..e7f5d53846
--- /dev/null
+++ b/libraries/python-bigfloat/python-bigfloat.info
@@ -0,0 +1,10 @@
+PRGNAM="python-bigfloat"
+VERSION="0.2.1"
+HOMEPAGE="http://bitbucket.org/dickinsm/bigfloat"
+DOWNLOAD="http://pypi.python.org/packages/source/b/bigfloat/bigfloat-0.2.1.tar.gz"
+MD5SUM="5260728c060ce511b6e23018b76fc2e0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="John Tyree"
+EMAIL="johntyree+removethis@gmail.com"
+APPROVED="Niels Horn"
diff --git a/libraries/python-bigfloat/slack-desc b/libraries/python-bigfloat/slack-desc
new file mode 100644
index 0000000000..fa8a0ca230
--- /dev/null
+++ b/libraries/python-bigfloat/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-bigfloat: python-bigfloat (Arbitrary precision floating point arithmetic)
+python-bigfloat:
+python-bigfloat: The bigfloat module is a Python wrapper for the MPFR library for
+python-bigfloat: arbitrary precision floating-point reliable arithmetic.
+python-bigfloat:
+python-bigfloat: The MPFR library is a well-known portable C library for
+python-bigfloat: arbitrary-precision arithmetic on floating-point numbers. It provides
+python-bigfloat: precise control over precisions and rounding modes and gives
+python-bigfloat: correctly-rounded reproducible platform-independent results.
+python-bigfloat:
+python-bigfloat:
+