summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Robby Workman2011-03-04 20:45:55 +0100
committer Niels Horn2011-03-04 20:45:55 +0100
commitb5259a5f2446b8dcf5a8ee64c1646531383de89a (patch)
treea16e35c95615fe017d4c644bdcbd7a718065e2a9
parente04ca096215d9771e37bc15a9afdbcf17fca3442 (diff)
downloadslackbuilds-b5259a5f2446b8dcf5a8ee64c1646531383de89a.tar.gz
libraries/python-cmdln: Added (enhanced cmdln module for python)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--libraries/python-cmdln/README3
-rw-r--r--libraries/python-cmdln/python-cmdln.SlackBuild87
-rw-r--r--libraries/python-cmdln/python-cmdln.info10
-rw-r--r--libraries/python-cmdln/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/libraries/python-cmdln/README b/libraries/python-cmdln/README
new file mode 100644
index 0000000000..af5dcdcb71
--- /dev/null
+++ b/libraries/python-cmdln/README
@@ -0,0 +1,3 @@
+cmdln.py fixes some of the design flaws in cmd.py and takes advantage
+of new Python stdlib modules (e.g. optparse) so that it is more useful
+(and convenient) for implementing command-line scripts/shells.
diff --git a/libraries/python-cmdln/python-cmdln.SlackBuild b/libraries/python-cmdln/python-cmdln.SlackBuild
new file mode 100644
index 0000000000..bcd5978418
--- /dev/null
+++ b/libraries/python-cmdln/python-cmdln.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for python-cmdln
+
+# Copyright 2011 Robby Workman, Northport, Alabama, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-cmdln
+VERSION=${VERSION:-1.1.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=cmdln
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+unzip $CWD/$SRCNAM-$VERSION.zip
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt docs/* examples $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-cmdln/python-cmdln.info b/libraries/python-cmdln/python-cmdln.info
new file mode 100644
index 0000000000..29f6d53957
--- /dev/null
+++ b/libraries/python-cmdln/python-cmdln.info
@@ -0,0 +1,10 @@
+PRGNAM="python-cmdln"
+VERSION="1.1.2"
+HOMEPAGE="https://code.google.com/p/cmdln/"
+DOWNLOAD="http://cmdln.googlecode.com/files/cmdln-1.1.2.zip"
+MD5SUM="d40a36d0c7b2a23c65a6ab1f213ddc0a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Robby Workman"
+EMAIL="rw@rlworkman.net"
+APPROVED="Niels Horn"
diff --git a/libraries/python-cmdln/slack-desc b/libraries/python-cmdln/slack-desc
new file mode 100644
index 0000000000..b0e722e417
--- /dev/null
+++ b/libraries/python-cmdln/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-cmdln: python-cmdln (enhanced cmdln module for python)
+python-cmdln:
+python-cmdln: cmdln.py fixes some of the design flaws in cmd.py and takes
+python-cmdln: advantage of new Python stdlib modules (e.g. optparse) so that
+python-cmdln: it is more useful (and convenient) for implementing command-line
+python-cmdln: scripts/shells.
+python-cmdln:
+python-cmdln:
+python-cmdln:
+python-cmdln:
+python-cmdln: