summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Bending Unit 6472010-12-12 19:48:30 +0100
committer Robby Workman2010-12-12 19:48:30 +0100
commit6abb907f4de2f972ca9ac881c8fe9f0d36c23a4e (patch)
treed1e3489f9b11b4fee7c39c908da2373cb6e827fd
parent51bcd4d2a122feb414b380e500ed4ca593a2902c (diff)
downloadslackbuilds-6abb907f4de2f972ca9ac881c8fe9f0d36c23a4e.tar.gz
office/elyxer: Updated for version 1.0.3.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--office/elyxer/README4
-rw-r--r--office/elyxer/elyxer.SlackBuild9
-rw-r--r--office/elyxer/elyxer.info6
-rw-r--r--office/elyxer/elyxer.sh2
-rw-r--r--office/elyxer/slack-desc7
5 files changed, 14 insertions, 14 deletions
diff --git a/office/elyxer/README b/office/elyxer/README
index 39d3b9804f..fcedeef239 100644
--- a/office/elyxer/README
+++ b/office/elyxer/README
@@ -1,4 +1,4 @@
-eLyXer (pronounced elixir) is a LyX to HTML converter. Using eLyXer,
-you can build a web representation of your documentation written with LyX.
+eLyXer (pronounced elixir) is a LyX to HTML converter. Using eLyXer, you
+can build a web representation of your documentation written with LyX.
eLyXer is a python module, but a wrapper script is provided.
diff --git a/office/elyxer/elyxer.SlackBuild b/office/elyxer/elyxer.SlackBuild
index 2b792092f8..8f28f2c7e2 100644
--- a/office/elyxer/elyxer.SlackBuild
+++ b/office/elyxer/elyxer.SlackBuild
@@ -9,12 +9,10 @@ VERSION=${VERSION:-1.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -58,13 +56,14 @@ python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mkdir -p $PKG/usr/bin
+cat $CWD/elyxer.sh > $PKG/usr/bin/elyxer
+chmod 0755 $PKG/usr/bin/elyxer
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README gpl-3.0-standalone.html docs $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-mkdir -p $PKG/usr/bin
-cat $CWD/elyxer.sh > $PKG/usr/bin/elyxer && chmod 0755 $PKG/usr/bin/elyxer
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/office/elyxer/elyxer.info b/office/elyxer/elyxer.info
index 7eeda9d090..10a57631c1 100644
--- a/office/elyxer/elyxer.info
+++ b/office/elyxer/elyxer.info
@@ -1,10 +1,10 @@
PRGNAM="elyxer"
-VERSION="1.0.2"
+VERSION="1.0.3"
HOMEPAGE="http://elyxer.nongnu.org/"
DOWNLOAD="http://download.savannah.gnu.org/releases/elyxer/elyxer-1.0.3.tar.gz"
-DOWNLOAD_x86_64=""
MD5SUM="06be63a5efbd1be566f2fb26f02259a8"
+DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Bending Unit 647"
EMAIL="bender647[at]gmail[dot]com"
-APPROVED="dsomero"
+APPROVED="rworkman"
diff --git a/office/elyxer/elyxer.sh b/office/elyxer/elyxer.sh
index e55d65534d..98e1424779 100644
--- a/office/elyxer/elyxer.sh
+++ b/office/elyxer/elyxer.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-python -m elyxer $@
+python -m elyxer "$@"
diff --git a/office/elyxer/slack-desc b/office/elyxer/slack-desc
index 9da731abab..13a3579aa6 100644
--- a/office/elyxer/slack-desc
+++ b/office/elyxer/slack-desc
@@ -9,11 +9,12 @@
elyxer: elyxer (Lyx to HTML converter)
elyxer:
elyxer: eLyXer is a LyX to HTML converter, implemented as a python module.
-elyxer: While there are a ton of such projects all over the web, eLyXer has a
-elyxer: clear focus on flexibility and elegant output. Installing eLyXer adds
-elyxer: HTML export capability to LyX.
+elyxer: While there are a ton of such projects all over the web, eLyXer has
+elyxer: a clear focus on flexibility and elegant output. Installing eLyXer
+elyxer: adds HTML export capability to LyX.
elyxer:
elyxer: Project website: http://elyxer.nongnu.org/
elyxer:
elyxer: User guide: http://elyxer.nongnu.org/userguide.html
elyxer:
+elyxer: