summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Kyle Guinn2010-05-13 00:33:23 +0200
committer David Somero2010-05-13 00:33:23 +0200
commitda921c166da83672858e60697e9f80e60c4d1b3f (patch)
tree3217ebcf7e1bfadf8e2787e12a6b70a67f56ad11
parent7f89ac5dea5f07ea3f46b3ebebf5efaf5aad05b4 (diff)
downloadslackbuilds-da921c166da83672858e60697e9f80e60c4d1b3f.tar.gz
libraries/pyusb: Updated for version 0.4.1
-rw-r--r--libraries/pyusb/pyusb.SlackBuild13
-rw-r--r--libraries/pyusb/pyusb.info4
2 files changed, 11 insertions, 6 deletions
diff --git a/libraries/pyusb/pyusb.SlackBuild b/libraries/pyusb/pyusb.SlackBuild
index 6099d16163..2a3f897308 100644
--- a/libraries/pyusb/pyusb.SlackBuild
+++ b/libraries/pyusb/pyusb.SlackBuild
@@ -18,10 +18,13 @@ DOCS="PKG-INFO README license.txt"
if [ $ARCH = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ $ARCH = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ $ARCH = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e
@@ -44,10 +47,10 @@ CXXFLAGS="$SLKCFLAGS" \
python ./setup.py install --root=$PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : \
- | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : \
- | xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : \
+ | xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : \
+ | xargs strip --strip-unneeded 2> /dev/null || true
)
# Normalize line endings
@@ -61,4 +64,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pyusb/pyusb.info b/libraries/pyusb/pyusb.info
index 34b32f3f4b..aa61a24acd 100644
--- a/libraries/pyusb/pyusb.info
+++ b/libraries/pyusb/pyusb.info
@@ -2,7 +2,9 @@ PRGNAM="pyusb"
VERSION="0.4.1"
HOMEPAGE="http://pyusb.berlios.de/"
DOWNLOAD="http://downloads.sourceforge.net/pyusb/pyusb-0.4.1.tar.gz"
+DOWNLOAD_x86_64=""
MD5SUM="9576c3e471e40e021fa44f36712bbd04"
+MD5SUM_x86_64=""
MAINTAINER="Kyle Guinn"
EMAIL="elyk03@gmail.com"
-APPROVED="David Somero" \ No newline at end of file
+APPROVED="dsomero" \ No newline at end of file