summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Richard Ellis2010-10-25 04:28:53 +0200
committer Erik Hanson2010-10-25 14:55:11 +0200
commit7195e67f85b8eb69f3c705efaa7eff82e892f672 (patch)
treec85899146fd8c85c4f95f8fe0089da1258908389
parentadcfe4d45100dc798829dedcafb9e763966c1402 (diff)
downloadslackbuilds-7195e67f85b8eb69f3c705efaa7eff82e892f672.tar.gz
system/duplicity: Added (Encrypted backup using rsync algorithm)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--system/duplicity/README10
-rw-r--r--system/duplicity/duplicity.SlackBuild73
-rw-r--r--system/duplicity/duplicity.info10
-rw-r--r--system/duplicity/slack-desc20
4 files changed, 113 insertions, 0 deletions
diff --git a/system/duplicity/README b/system/duplicity/README
new file mode 100644
index 0000000000..07eb40cdd9
--- /dev/null
+++ b/system/duplicity/README
@@ -0,0 +1,10 @@
+duplicity - Encrypted bandwidth-efficient backup using rsync algorithm
+
+Duplicity backs up directories by producing encrypted tar-format volumes and
+uploading them to a remote or local file server. Because duplicity uses
+librsync, the incremental archives are space efficient and only record the
+parts of files that have changed since the last backup. Because duplicity
+uses GnuPG to encrypt and/or sign these archives, they will be safe from
+spying and/or modification by the server.
+
+This requires librsync
diff --git a/system/duplicity/duplicity.SlackBuild b/system/duplicity/duplicity.SlackBuild
new file mode 100644
index 0000000000..2f584b6a4b
--- /dev/null
+++ b/system/duplicity/duplicity.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+# Slackware build script for duplicity
+
+# Written by Richard Ellis <rellis@dp100.com>
+
+# This script is hereby released into the public domain.
+
+PRGNAM=duplicity
+VERSION=${VERSION:-0.6.10}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Strip binaries and libraries.
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mv $PKG/usr/share/doc $PKG/usr/
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/duplicity/duplicity.info b/system/duplicity/duplicity.info
new file mode 100644
index 0000000000..f33bef3681
--- /dev/null
+++ b/system/duplicity/duplicity.info
@@ -0,0 +1,10 @@
+PRGNAM="duplicity"
+VERSION="0.6.10"
+HOMEPAGE="http://duplicity.nongnu.org/"
+DOWNLOAD="http://code.launchpad.net/duplicity/0.6-series/0.6.10/+download/duplicity-0.6.10.tar.gz"
+MD5SUM="8878d3b63fcba1b7233e11c5829b969c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Richard Ellis"
+EMAIL="rellis@dp100.com"
+APPROVED="dsomero"
diff --git a/system/duplicity/slack-desc b/system/duplicity/slack-desc
new file mode 100644
index 0000000000..50286808dd
--- /dev/null
+++ b/system/duplicity/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+duplicity: duplicity (Encrypted bandwidth-efficient backup using rsync algorithm)
+duplicity:
+duplicity: Duplicity backs directories by producing encrypted tar-format volumes
+duplicity: and uploading them to a remote or local file server. Because duplicity
+duplicity: uses librsync, the incremental archives are space efficient and only
+duplicity: record the parts of files that have changed since the last backup.
+duplicity: Because duplicity uses GnuPG to encrypt and/or sign these archives,
+duplicity: they will be safe from spying and/or modification by the server.
+duplicity:
+duplicity:
+duplicity:
+