summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Mikko Varri2010-03-16 18:13:03 +0100
committer Erik Hanson2010-05-13 13:31:26 +0200
commit41f5ac2990d413157157cdfe2a194cc3f24a7893 (patch)
tree5a1176eb7a0dbf54c9ba4c14a4776fd8ea5e031e
parent2d9d906b004053244cba433900fad0fbaf4a9ed6 (diff)
downloadslackbuilds-41f5ac2990d413157157cdfe2a194cc3f24a7893.tar.gz
desktop/dzen2: Added.
Dzen is a general purpose messaging, notification, and menuing application. Thanks to Mikko Varri.
-rw-r--r--desktop/dzen2/README7
-rw-r--r--desktop/dzen2/dzen2.SlackBuild92
-rw-r--r--desktop/dzen2/dzen2.info10
-rw-r--r--desktop/dzen2/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/desktop/dzen2/README b/desktop/dzen2/README
new file mode 100644
index 0000000000..b720a0f5e3
--- /dev/null
+++ b/desktop/dzen2/README
@@ -0,0 +1,7 @@
+Dzen is a general purpose messaging, notification, and menuing application.
+
+Visit the Wiki at http://dzen.geekmode.org/dwiki/doku.php?id=dzen:mainindex
+in order to find scripts and icon packs.
+
+Modify the SlackBuild if you want XPM and/or Xinerama support. They
+are disabled by default.
diff --git a/desktop/dzen2/dzen2.SlackBuild b/desktop/dzen2/dzen2.SlackBuild
new file mode 100644
index 0000000000..74cc31b1a1
--- /dev/null
+++ b/desktop/dzen2/dzen2.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for dzen2
+
+# Written by Grigorios Bouzakis (grbzks@gmail.com)
+# Written by Mikko Varri (vmj@linuxbox.fi)
+# Public domain.
+
+PRGNAM=dzen2
+VERSION=${VERSION:-0.8.5}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# configure
+# - uncomment the second sed invocation to add XPM support
+# - uncomment the third sed invocation to add Xinerama support
+sed -s -i \
+ -e "s/^LIBS = -L\/usr\/lib/LIBS = -L\/usr\/lib${LIBDIRSUFFIX}/" \
+ -e "s/^CFLAGS = -Os/CFLAGS = ${SLKCFLAGS}/" \
+ config.mk \
+ gadgets/config.mk
+#sed -i -e "s/^LIBS = .*/& -lXpm/" -e "s/^CFLAGS = .*/& -DDZEN_XPM/" config.mk
+#sed -i -e "s/^LIBS = .*/& -lXinerama/" -e "s/^CFLAGS = .*/& -DDZEN_XINERAMA/" config.mk
+
+
+# build dzen and gadgets
+make install \
+ PREFIX=/usr \
+ MANPREFIX=/usr/man \
+ X11INC=/usr/include/X11 \
+ X11LIB=/usr/lib${LIBDIRSUFFIX}/X11 \
+ DESTDIR=$PKG
+make -C gadgets install \
+ PREFIX=/usr \
+ MANPREFIX=/usr/man \
+ X11INC=/usr/include/X11 \
+ X11LIB=/usr/lib${LIBDIRSUFFIX}/X11 \
+ DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CREDITS INSTALL LICENSE README* \
+ gadgets/*.sh gadgets/README.* \
+ bitmaps \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/dzen2/dzen2.info b/desktop/dzen2/dzen2.info
new file mode 100644
index 0000000000..f735bdc1ab
--- /dev/null
+++ b/desktop/dzen2/dzen2.info
@@ -0,0 +1,10 @@
+PRGNAM="dzen2"
+VERSION="0.8.5"
+HOMEPAGE="http://gotmor.googlepages.com/dzen"
+DOWNLOAD="http://gotmor.googlepages.com/dzen2-0.8.5.tar.gz"
+MD5SUM="5978620c2124c8a8ad52d7f17ce94fd7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Mikko Varri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="Erik Hanson"
diff --git a/desktop/dzen2/slack-desc b/desktop/dzen2/slack-desc
new file mode 100644
index 0000000000..fab3ede030
--- /dev/null
+++ b/desktop/dzen2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+dzen2: dzen2 (General purpose messaging and notification program)
+dzen2:
+dzen2: Dzen is a general purpose messaging, notification, and menuing
+dzen2: application.
+dzen2:
+dzen2: Homepage: http://gotmor.googlepages.com/dzen
+dzen2:
+dzen2:
+dzen2:
+dzen2:
+dzen2: