summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-03-31 22:35:30 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:17 +0200
commit91884824ec458632ea7283f100986144764dfb44 (patch)
tree545d0acbd651904d7635dd8b402b911963d0b05c
parent0fb5e7aab04fb9921fcc8d0c9111eb57ac5e25ea (diff)
downloadslackbuilds-91884824ec458632ea7283f100986144764dfb44.tar.gz
python/python3-statsmodels: Fix PYTHONPATH.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-statsmodels/python3-statsmodels.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/python/python3-statsmodels/python3-statsmodels.SlackBuild b/python/python3-statsmodels/python3-statsmodels.SlackBuild
index 48e6761ccb..62d10dc7a9 100644
--- a/python/python3-statsmodels/python3-statsmodels.SlackBuild
+++ b/python/python3-statsmodels/python3-statsmodels.SlackBuild
@@ -74,7 +74,8 @@ sed -i '/oldest-supported-numpy/d' pyproject.toml
# convert to minimum req'd instead of pinned
sed -i 's/\(setuptools_scm.*\)~=/\1>=/' pyproject.toml
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl