summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-03-31 19:33:44 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:14 +0200
commit8e29a22730832b1689b348501182e2f8f6905f8e (patch)
treec349a3e6186f1ca7b6d816322ab797413c4397b7
parent8d3983358987f4f025f784aff959d6d0c56cd5c5 (diff)
downloadslackbuilds-8e29a22730832b1689b348501182e2f8f6905f8e.tar.gz
python/python3-dulwich: Fix PYTHONPATH.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-dulwich/python3-dulwich.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/python/python3-dulwich/python3-dulwich.SlackBuild b/python/python3-dulwich/python3-dulwich.SlackBuild
index af3c42eea8..83ecf9b137 100644
--- a/python/python3-dulwich/python3-dulwich.SlackBuild
+++ b/python/python3-dulwich/python3-dulwich.SlackBuild
@@ -64,7 +64,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \