summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-03-31 22:38:45 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:19 +0200
commit54672901385fe5a93e94a02ea41b73750b86d4f9 (patch)
treeb0c506d31566bbb107fa7b6d367dba69c0329fbf
parente76c78ece709625cc50caf6c72d7426f852c7b8d (diff)
downloadslackbuilds-54672901385fe5a93e94a02ea41b73750b86d4f9.tar.gz
python/python3-pykeepass: Fix FTB and PYTHONPATH.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-pykeepass/python3-pykeepass.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/python3-pykeepass/python3-pykeepass.SlackBuild b/python/python3-pykeepass/python3-pykeepass.SlackBuild
index a5a0d11d14..4f23b98d47 100644
--- a/python/python3-pykeepass/python3-pykeepass.SlackBuild
+++ b/python/python3-pykeepass/python3-pykeepass.SlackBuild
@@ -64,6 +64,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# fix dos line endings or patch will fail
+perl -pi -e 's/\r\n/\n/g' pyproject.toml
+
# Fix missing pykeepass.kdbx_parsing when built with modern tools
# https://github.com/libkeepass/pykeepass/pull/378
patch -p1 < $CWD/fix_missing_pykeepass_kdbx_parsing.patch
@@ -72,7 +75,8 @@ patch -p1 < $CWD/fix_missing_pykeepass_kdbx_parsing.patch
# https://github.com/libkeepass/pykeepass/pull/383
patch -p1 < $CWD/use_built_in_isoformat_support.patch
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl