summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-03-31 19:33:40 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:08 +0200
commit1e152a2a5bbfbe421cdb2120cfa42fdb33a53392 (patch)
treea911e1f4233a11b31e032fb7b201104f70c9db06
parent3a68f9ebd4a126e344255e922a005c80deeec105 (diff)
downloadslackbuilds-1e152a2a5bbfbe421cdb2120cfa42fdb33a53392.tar.gz
academic/rpy2: Fix PYTHONPATH.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--academic/rpy2/rpy2.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/academic/rpy2/rpy2.SlackBuild b/academic/rpy2/rpy2.SlackBuild
index e31ee651c0..23396b09d6 100644
--- a/academic/rpy2/rpy2.SlackBuild
+++ b/academic/rpy2/rpy2.SlackBuild
@@ -100,7 +100,8 @@ echo "LD_LIBRARY_PATH set to ${LD_LIBRARY_PATH}"
# replace deprecated `python3 setup.py build install --root=$PKG`
# thanks to fourtysixandtwo
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl