summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-03-31 19:33:40 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:09 +0200
commit148dcb54b830a95721fcb80c11d30462dbfb8c8e (patch)
tree37001845dddfa5a27a134ca9eebacf23b7d80890
parent3eacde769ef3ca4fd492d1cb0ff9aa6556cc0bae (diff)
downloadslackbuilds-148dcb54b830a95721fcb80c11d30462dbfb8c8e.tar.gz
gis/python3-shapely: Fix PYTHONPATH.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--gis/python3-shapely/python3-shapely.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/gis/python3-shapely/python3-shapely.SlackBuild b/gis/python3-shapely/python3-shapely.SlackBuild
index 20da7f0a13..12a2c42b8b 100644
--- a/gis/python3-shapely/python3-shapely.SlackBuild
+++ b/gis/python3-shapely/python3-shapely.SlackBuild
@@ -74,7 +74,8 @@ sed -i 's/oldest-supported-numpy/numpy>=1.19.3/' pyproject.toml
# Requires newer version of setuptools than available in -stable. Has not
# effect on -current
-export PYTHONPATH=/opt/python3.9/site-packages
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl