summaryrefslogtreecommitdiffstats
path: root/system/statifier/statifier.SlackBuild
blob: 3ce16e89147dbc719d4971932d6d69f8bd658b62 (plain)
#!/bin/sh

# Slackware build script for statifier

# Written by Niels Horn <email removed>, revision date: 2010/03/13
# Updated by Willy Sudiarto Raharjo <email removed>
# Updated again and now maintained by B. Watson <yalhcru@gmail.com>

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20180118 bkw:
# - take over maintenance.
# - update for v1.7.4.
# - grammar nitpicks in README and slack-desc.
# - add useful info to README, like how to actually get this to work.
# - add patch to help the user remember to disable VDSO.

PRGNAM=statifier
VERSION=${VERSION:-1.7.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  LIBDIRSUFFIX="64"
else
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \+ -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \+

# We need to patch config.x86_64 because Slackware64 is not multi-lib and we
# only have the 32-bits libraries
patch -p1 < $CWD/64pure.patch

# If VDSO is enabled, print a warning and directions on how to disable it.
patch -p1 < $CWD/detect_vdso.diff

# "usr/lib/" is hardcoded in the Makefile...
sed -i "s,usr/lib/,usr/lib${LIBDIRSUFFIX}/," src/Makefile
# And in the startup script...
sed -i "s,usr/lib/,usr/lib${LIBDIRSUFFIX}/," src/statifier

# The "configure" script is run by "make" and we really should not mess with
# the CFLAGS & options
# Make *needs* to be run with "-j1" or strange things may happen...
MAKEFLAGS="" make -j1
make install DESTDIR=$PKG

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

gzip $PKG/usr/man/man1/$PRGNAM.1

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
  AUTHORS ChangeLog FAQ INSTALL LICENSE NEWS \
  README RELEASE THANKS TODO VERSION doc \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}