summaryrefslogtreecommitdiffstats
path: root/system/passwordsafe/passwordsafe.SlackBuild
blob: 480eba6469490b0d010b6a42cd7439fbfcf29c91 (plain)
#!/bin/sh

# Slackware build script for passwordsafe

# Copyright 2015 rfmae <rf.mae.git@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=passwordsafe
VERSION=${VERSION:-1.02BETA}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
SRCNAM=pwsafe

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

# Check for YubiKey support.
YUBI_DISABLED=${NO_YUBI}
if [ -n "${NO_YUBI-}" ] || [ "${NO_YUBI+x}" = x ]; then
  YUBI_DISABLED=1
else
  YUBI_DISABLED=0
fi

if [ $YUBI_DISABLED -ne 1 ]; then
  SLKCFLAGS="$SLKCFLAGS -I/usr/include/ykpers-1"
fi

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
 -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

# Change path to help and xml files to the proper directory.
patch -p1 < $CWD/01_help-xml.patch

CFLAGS="$SLKCFLAGS"
CXXFLAGS="$SLKCFLAGS"

make -j1 clean
make -j1 release
cd help
make -j1
cd ../src/ui/wxWidgets/I18N
make -j1 mos

cd $TMP/$SRCNAM-$VERSION
mkdir -p $PKG/usr/bin
cp -a src/ui/wxWidgets/GCCUnicodeRelease/pwsafe $PKG/usr/bin

mkdir -p $PKG/usr/man/man1
cp -a docs/pwsafe.1 $PKG/usr/man/man1
mkdir -p $PKG/usr/share/{pixmaps,applications,locale}
cp -a install/graphics/pwsafe.png $PKG/usr/share/pixmaps/$PRGNAM.png
cp -a install/desktop/pwsafe.desktop $PKG/usr/share/applications/$PRGNAM.desktop
cp -aR src/ui/wxWidgets/I18N/mos/* $PKG/usr/share/locale

find $PKG -type f -print0 | xargs -0 --no-run-if-empty chmod 644
chmod 755 $PKG/usr/bin/*

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/docs
cp -a docs/*.{txt,rtf,html} $PKG/usr/doc/$PRGNAM-$VERSION/docs
cp -a README* LICENSE install/copyright $PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/usr/share/$PRGNAM/{help,xml}
cp -a help/help*.zip $PKG/usr/share/$PRGNAM/help
cp -a xml/* $PKG/usr/share/$PRGNAM/xml
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

# Compress program documentation files > 4k.
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -size 4k ! -iname *.htm ! -iname *.html \
  ! -iname *.sh ! -iname *.zip -print0 | xargs -0 --no-run-if-empty /bin/gzip \
  --verbose --best

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}