summaryrefslogtreecommitdiffstats
path: root/office/texlive/texlive.SlackBuild
blob: 5028a03de3dea7c51cd537f398eb0324b01c9bef (plain)
#!/bin/sh

# TeXLive build script for Slackware

# Copyright 2009  Patrick J. Volkerding, Sebeka, MN, USA
# Copyright 2009-2014  Robby Workman, Northport, AL, USA
# Copyright 2016  Johannes Schoepfer
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# URL: ftp://tug.org/historic/systems/texlive/
# Testrelease: ftp://tug.org/texlive/Images/test/

PRGNAM=texlive
SOURCEVERSION=20160523
VERSION=${VERSION:-2016.161031}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-texlive
OUTPUT=${OUTPUT:-/tmp}

set -e

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf texlive-$SOURCEVERSION-source
tar xvf $CWD/texlive-${SOURCEVERSION}b-source.tar.xz
cd texlive-$SOURCEVERSION-source
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .

export LANG=C
export PATH="$PKG/usr/bin:$PATH"
export LD_LIBRARY_PATH="$PKG/usr/lib${LIBDIRSUFFIX}:$LD_LIBRARY_PATH"

# set TEXMFROOT and TEXMFLOCAL
sed -i \
  -e 's|^TEXMFROOT.*|TEXMFROOT = $SELFAUTODIR/share|' \
  -e 's|^TEXMFLOCAL.*|TEXMFLOCAL = $TEXMFROOT/texmf-local|' \
  texk/kpathsea/texmf.cnf

# Fix a segfault in upmendex, thanks to the lfs-folks.
patch -Np1 -i $CWD/patches/texlive-20160523b-source-upstream_fixes-1.patch

# --with-system-harfbuzz requires graphite2 (and harfbuzz linked to it)
mkdir build
pushd build
  CFLAGS="$SLKCFLAGS" \
  CXXFLAGS="$SLKCFLAGS" \
  ../configure \
    --prefix=/usr \
    --libdir=/usr/lib${LIBDIRSUFFIX} \
    --mandir=/usr/man \
    --infodir=/usr/info \
    --with-banner-add=' on Slackware (SlackBuilds.org)' \
    --disable-native-texlive-build \
    --enable-largefile \
    --enable-shared \
    --disable-static \
    --disable-missing \
    --disable-multiplatform \
    --disable-debug \
    --with-x \
    --enable-xindy \
    --disable-xindy-docs \
    --disable-xindy-rules \
    --with-clisp-runtime=system \
    --enable-gc=system \
    --with-system-poppler \
    --with-system-xpdf \
    --with-system-zlib \
    --with-system-libpng \
    --with-system-t1lib \
    --with-system-gd \
    --with-system-freetype2 \
    --with-system-libgs \
    --with-system-icu \
    --with-system-pixman \
    --with-system-cairo \
    --with-system-gmp \
    --with-system-mpfr \
    --with-system-fontconfig \
    --with-system-ncurses \
    --build=$ARCH-slackware-linux
  make
  # make check
  make install-strip DESTDIR=$PKG
  # Create symlinks
  make texlinks DESTDIR=$PKG
popd

# install the texmf stuff, overwrite partly stuff coming from the source build;
# don't remove/separate koma-script docs as this is the wish of the author
mkdir -p $PKG/usr/share
tar vxf $CWD/texlive-base-$VERSION.tar.xz -C $PKG/usr/share
chown -R root:root $PKG
chmod -R u+w,go-w,a+rX-st $PKG

# Move biber binary to $PATH
case $ARCH in
	"x86_64") mv $PKG/usr/share/texmf-dist/bin/x86_64-linux/biber $PKG/usr/bin ;;
	"i586") mv $PKG/usr/share/texmf-dist/bin/i386-linux/biber $PKG/usr/bin ;;
esac
rm -rf $PKG/usr/share/texmf-dist/bin

# Remove mpost from shell_escape_commands, http://tug.org/pipermail/tldistro/2016q4/000277.html
sed -i \
  -e '/^mpost/d' \
  $PKG/usr/share/texmf-dist/web2c/texmf.cnf

# set some paths
sed -i \
  -e 's|^TEXMFROOT.*|TEXMFROOT = $SELFAUTODIR/share|' \
  -e 's|^TEXMFLOCAL.*|TEXMFLOCAL = $TEXMFROOT/texmf-local|' \
  -e 's|^OSFONTDIR.*|OSFONTDIR = ~/.fonts:/usr/share/fonts|' \
  -e 's|texlive20[0-9][0-9]|texlive|g' \
  $PKG/usr/share/texmf-dist/web2c/texmf.cnf

# make ConTeXt work, and remove unused settings
sed -i \
  -e 's|selfautoparent:|/usr/share/|g' \
  -e 's|\(TEXMFLOCAL[ ]*=[ ]*\)[^,]*|\1"/usr/share/texmf-local"|' \
  -e 's|texlive20[0-9][0-9]|texlive|g' \
  -e '/selfautodir/d' \
  -e '/texmflocal/d' \
  $PKG/usr/share/texmf-dist/web2c/texmfcnf.lua

# Install the docs while we're still here
mkdir -p $PKG/usr/doc/texlive-$VERSION
cp -a ChangeLog README* $PKG/usr/doc/texlive-$VERSION

# Put a symlink to /usr/share/texmf-dist/doc in our Slackware docdir
ln -s ../../share/texmf-dist/doc $PKG/usr/doc/texlive-$VERSION/doc

# We won't make tlmgr easily available; it's still there, but
# we'll make it harder to void the warranty :-)
rm -f $PKG/usr/bin/tlmgr
cat $CWD/README.tlpkg > $PKG/usr/doc/texlive-$VERSION/README.tlpkg

# Create some directories to make it clear that they're owned by this package
mkdir -p $PKG/usr/share/{texmf-config,texmf-var,texmf-local}

# Add some perl modules, at least one of which is required by updmap
mkdir -p $PKG/usr/share/perl5
mv texk/tests/TeXLive $PKG/usr/share/perl5/

# Handle the man pages
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $(find $PKG/usr/man -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done

# Handle the GNU info pages
rm -f $PKG/usr/info/dir
gzip -9 $PKG/usr/info/*

mkdir -p $PKG/install
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}