summaryrefslogtreecommitdiffstats
path: root/office/texlive-docs/texlive-docs.SlackBuild
blob: 7e8b2792271cc2d30598afac503d4f7053df397f (plain)
#!/bin/bash

# texlive-docs build script for Slackware

# Copyright 2009  Patrick J. Volkerding, Sebeka, MN, USA
# Copyright 2009 - 2014  Robby Workman, Northport, AL, USA
# Copyright 2016 - 2021  Johannes Schoepfer, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=texlive-docs
TEXMFVERSION=${TEXMFVERSION:-210418}
VERSION=${VERSION:-2021.210418}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

ARCH=noarch

TEXMFROOT=/usr/share

set -e

rm -rf $PKG
mkdir -p $TMP $PKG$TEXMFROOT $OUTPUT $PKG/usr/doc/texlive-$VERSION
tar xvf $CWD/$PRGNAM-$TEXMFVERSION.tar.xz -C $PKG$TEXMFROOT
chown -R root:root $PKG
chmod -R u+w,go-w,a+rX-st $PKG

# No, we don't care about the pdf versions of the manual pages
rm -rf $PKG$TEXMFROOT/texmf-dist/doc/man

# Install index of provided tex packages to the docs
mv $PKG$TEXMFROOT/texmf-dist/packages.docs.gz $PKG/usr/doc/texlive-$VERSION

mkdir -p $PKG/install
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE