summaryrefslogtreecommitdiffstats
path: root/network/zarafa/zarafa.SlackBuild
blob: 7a9b6f8949931af6cd9425b3e904c611caa393aa (plain)
#!/bin/sh

# Slackware build script for zarafa:
# an MS Exchange substitute

# Copyright 2009-2011  Niels Horn, Rio de Janeiro, RJ, Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# revision date 2011/09/16

PRGNAM=zarafa
VERSION=${VERSION:-7.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

SRCNAM=zcp

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .

# With gcc-4.7.x we need a little patch
patch -p1 < $CWD/gcc47.patch

VMIME_LIBS="-lvmime_zarafa" \
VMIME_CFLAGS="-I/usr/include/vmime_zarafa" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --localstatedir=/var \
  --mandir=/usr/man \
  --docdir=/usr/doc/$PRGNAM-$VERSION \
  --sysconfdir=/etc \
  --disable-static \
  --enable-icu \
  --with-userscript-prefix=/etc/zarafa/userscripts \
  --with-quotatemplate-prefix=/etc/zarafa/quotamails \
  --with-vmime-prefix=/usr/include/vmime_zarafa \
  --with-clucene-lib-prefix=/usr/lib${LIBDIRSUFFIX} \
  --build=$ARCH-slackware-linux

# Use our CFLAGS
for mf in $(find . -name Makefile); do
  sed -i "/^C[X]*[X]*FLAGS/s/=/+=/" $mf
done

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
  make
make install DESTDIR=$PKG

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done

# Rename cfg files to .new
for cfg in $PKG/etc/$PRGNAM/*.cfg; do
  mv $cfg $cfg.new
done

# The doc of zarafa-gateway ends up in the wrong directory somehow...
mv $PKG/usr/doc/zarafa-gateway/* $PKG/usr/doc/$PRGNAM-$VERSION/
rmdir $PKG/usr/doc/zarafa-gateway

# Remove sysconfig files. We don't use them and they only set the collation,
# which is taken care of in the rc.* scripts as well
rm -rf $PKG/etc/sysconfig

# Move /etc/init.d scripts to /etc/rc.d with the correct naming
mkdir -p $PKG/etc/rc.d
for script in $PKG/etc/init.d/*; do
  rc=$(basename $script)
  mv $script $PKG/etc/rc.d/rc.$rc.new
  chmod -x $PKG/etc/rc.d/rc.$rc.new
done
rm -rf $PKG/etc/init.d

# Directory for log file
mkdir -p $PKG/var/log/$PRGNAM

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README.Slackware > $PKG/usr/doc/$PRGNAM-$VERSION/README.Slackware

mkdir -p $PKG/install
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}