summaryrefslogtreecommitdiffstats
path: root/network/snort/snort.SlackBuild
blob: 2bc47b6a568f49c551d41adc2536ff2f74dcddd0 (plain)
#!/bin/sh

# Copyright 2006-2009, Alan Hicks, Lizella, GA,
# Copyright 2009, Thomas York, Beech Grove, In.
# Copyright 2010-2012, Niels Horn, Rio de Janeiro, RJ, Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
# Modified by the SlackBuilds.org project
# Maintained by David Spencer <baildon.research@googlemail.com>

PRGNAM=snort
VERSION=${VERSION:-2.9.17}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION

# The Makefiles do not respect the --libdir setting, which causes the libs to
# go to /usr/lib/ on Slackware64. We'll "teach them" how to do it right :)
for mf in $( find src/ -name Makefile.in ) ; do
  sed -i "s|\${exec_prefix}/lib/snort_dynamic|@libdir@/snort_dynamic|g" $mf
done

# Similar problem with the --docdir in /doc/Makefile.in ...
sed -i "s|\${datadir}/doc/\${PACKAGE}|@docdir@|g" doc/Makefile.in

chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

NON_ETHERNET_DECODERS='--enable-non-ether-decoders'
if [ "${NON_ETHER:-yes}" = 'no' ]; then
  NON_ETHERNET_DECODERS=''
fi

CPPFLAGS="$CPPFLAGS -I/usr/include/tirpc/" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --mandir=/usr/man \
  --localstatedir=/var \
  --docdir=/usr/doc/$PRGNAM-$VERSION \
  --enable-pthread \
  --enable-linux-smp-stats \
  ${NON_ETHERNET_DECODERS} \
  --build=$ARCH-slackware-linux

make
make install-strip DESTDIR=$PKG

find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done

# Set up a sane config directory - snort won't do this on its own
mkdir -p $PKG/etc/$PRGNAM
# Fix paths for libraries in snort.conf, also 64-bits and rules paths...
# also set "unified2" as standard output, without special options
sed -e "s|usr/local/lib|usr/lib${LIBDIRSUFFIX}|g" \
    -e "s|PATH ../|PATH |g" \
    -e "/^# output unified2*/aoutput unified2: filename snort.log, limit 128" \
    etc/snort.conf > $PKG/etc/snort/snort.conf.new
cat etc/threshold.conf > $PKG/etc/snort/threshold.conf.new
cat etc/reference.config > $PKG/etc/snort/reference.config.new
cat etc/classification.config > $PKG/etc/snort/classification.config.new
cat etc/attribute_table.dtd > $PKG/etc/snort/attribute_table.dtd.new
cat etc/gen-msg.map > $PKG/etc/snort/gen-msg.map.new
cat etc/unicode.map > $PKG/etc/snort/unicode.map.new

# Create default, empty directory for rules
mkdir -p $PKG/etc/snort/rules
mkdir -p $PKG/etc/snort/preproc_rules

# Include the rc.snort file
mkdir -p $PKG/etc/rc.d
cat $CWD/rc.snort > $PKG/etc/rc.d/rc.snort.new
chmod 0755 $PKG/etc/rc.d/rc.snort.new

# Create directory for logging
mkdir -p $PKG/var/log/snort

# Create directories for schemas and signatures
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/{schemas,signatures}

# Create directory for dynamic rules
mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/snort_dynamicrules

cp -a COPYING ChangeLog LICENSE RELEASE.NOTES \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}