summaryrefslogtreecommitdiffstats
path: root/network/shorewall/shorewall.SlackBuild
blob: 3d7d9058a78ab7b769530c341061d726c3db719a (plain)
#!/bin/sh

# Slackware build script for shorewall

# Copyright (c) 2008-2009 Gregory J.L. Tourte (artourter@gmail.com)
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=shorewall
VERSION=${VERSION:-5.2.3.6}
ARCH=noarch
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

BASEVERS=$VERSION

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$BASEVERS
tar xvf $CWD/$PRGNAM-$BASEVERS.tar.bz2
cd $TMP/$PRGNAM-$BASEVERS
chown -R root:root .

./configure

DESTDIR=$PKG \
  ./install.sh

# Don't clobber config files
( cd $PKG/etc/shorewall
  for i in $(ls|grep -v Makefile) ; do
    mv $i $i.new;
  done
)
( cd $PKG/etc/rc.d/
  mv rc.shorewall rc.shorewall.new
)

chmod 0755 $PKG/{etc,usr/share,var/lib}/shorewall
chmod 0644 $PKG/etc/shorewall/* $PKG/etc/rc.d/*

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING INSTALL *.txt Samples $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

for NEW in $PKG/etc/shorewall/*.new;
do
     echo $NEW | sed 's/.*etc/config etc/' >> $PKG/install/doinst.sh
done

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

# Clean up the extra stuff:
if [ "$1" = "--cleanup" ]; then
  rm -rf $TMP/$PRGNAM-$BASEVERS
  rm -rf $PKG
fi