summaryrefslogtreecommitdiffstats
path: root/network/icecat/icecat.SlackBuild
blob: b7b8272b6669b8e51e022f337d116cd9197b6b7e (plain)
#!/bin/sh

# Slackware build script for icecat
# Written by David Negroni <dnegroni.italy@gmail.com>
# Modified by melikamp <melikamp@melikamp.net>

# This program is free software: it is placed into the Public Domain
# by the author. A verbose dedication is available at
# http://creativecommons.org/publicdomain/zero/1.0/legalcode

# This program is distributed in the hope that it will be useful, but
# without any warranty; compiling, interpreting, executing or merely
# reading the text of the program may result in lapses of consciousness
# and/or very being, up to and including the end of all existence and
# the Universe as we know it.

PRGNAM="icecat"
VERSION="5.0"
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/${PRGNAM}-$VERSION.tar.bz2 || exit 1
cd ${PRGNAM}-$VERSION
chown -R root:root .
find . \
 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

cp -v .mozconfig{,.orig}
sed '/--prefix/s:/usr/local:/usr:' .mozconfig.orig > .mozconfig

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --build=$ARCH-slackware-linux || exit 1

make || exit 1
make install DESTDIR=$PKG

# Stripping is done in .mozconfig, but there is something we can erase:
rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/icecat-devel-$VERSION
rm -rf $PKG/usr/include

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
  ChangeLog LEGAL LICENSE README.ICECAT README.txt config.cache \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}