summaryrefslogtreecommitdiffstats
path: root/network/dropbox/dropbox.SlackBuild
blob: 8cd65ecced840f763acbb6166e851f94e89f23e7 (plain)
#!/bin/sh

# Copyright 2014 Amit Ugol <amit.ugol@gmail.com>
#
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# Public changelog: https://www.dropbox.com/release_notes
# Changelog:
# 09/Jan/2015 * Updated to latest version 3.0.5
# 08/Jan/2015 * Updated to latest version 3.0.5
#               Tray icons will only work with compositing off.
# 18/Dec/2014 * Updated to latest version 3.0.4
#               Still no working tray icons.
#               Client RAM usage grew to more then 4GB after a week.
#               Maybe 3.1.X will be better...
# 09/Dec/2014 * Updated to latest version 3.0.3
#               There is a working tray icon but QT5 issues makes the icon's
#               background a hard black instead of transparent. I will wait
#               for a fix. Also note that the previous bug is not 100% solved.
#               https://bugreports.qt-project.org/browse/QTBUG-35832
# 08/Dec/2014 * Updated to latest version 3.0.2
#               This is still rough, though everything seems to sync, there
#               are no systray icons. The new interface is pure QT5 and this
#               have introduced some new issues:
#               https://bugreports.qt-project.org/browse/QTBUG-31762
#               Not sure this version will be added to SBo until its fixed.
# 16/Nov/2014 * Updated to latest version 2.10.52
# 11/Nov/2014 * Updated to latest version 2.10.50
# 14/Oct/2014 * Updated to latest version 2.10.41
# 16/Sep/2014 * Updated to latest version 2.10.30
# 20/Aug/2014 * Updated to latest version 2.10.29
#             * Updated to the direct download links
# 25/May/2014 * Updated to latest version 2.8.2
#             * Split the terms into sections, they are all in the docs folder
#             * Updated the logo
# 02/Mar/2014 * Updated to newest version 2.6.15
# 16/Nov/2013 * Updates for Slackware 14.1:
#             * Updated to newest version 2.4.6
#               _______________________________________________________________
# 09/Apr/2013 * Murat D. Kadirov <banderols@gmail.com> is MIA.
#             * Updated by Amit Ugol <amit.ugol@gmail.com>.
#             * Updated to version 2.0.5
#             * Changed the slac-desc to be up-to-date with the online info.
#             * Changed the terms file to be up-to-date with the online info.
#             * Removed deletion of libstdc++.so.6 as it is not there anyway.
#             * Since 2.0, dropbox seems to update itself and I find it working
#               rather well.
#             * Minor changes to this changelog.
# 18/Dec/2011 * Updated to 1.2.49
#             * Bug fixed with bad symlink to /usr/bin/dropboxd. Thanks to
#               Dominik Drobek.

PRGNAM=dropbox
PACKNAM=dropbox-lnx

VERSION=${VERSION:-3.0.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi


CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SOURCE="x86"
elif [ "$ARCH" = "i686" ]; then
  SOURCE="x86"
elif [ "$ARCH" = "x86_64" ]; then
  SOURCE="x86_64"
else
  SOURCE="x86"
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf .$PRGNAM-dist
tar xvf $CWD/$PACKNAM.$SOURCE-$VERSION.tar.gz
cd .$PRGNAM-dist
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

mkdir $PKG/opt
mkdir -p $PKG/usr/bin
cp -R ../.$PRGNAM-dist $PKG/opt/dropbox
ln -s /opt/dropbox/dropboxd $PKG/usr/bin/dropboxd
install -D -m 644 $CWD/dropbox.desktop $PKG/usr/share/applications/dropbox.desktop
install -D -m 644 $CWD/dropbox.png $PKG/usr/share/pixmaps/dropbox.png

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp $CWD/*.txt $PKG/usr/doc/$PRGNAM-$VERSION/
cp $CWD/$PRGNAM.SlackBuild $PKG/usr/doc/$PRGNAM-$VERSION/

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}