summaryrefslogtreecommitdiffstats
path: root/network/claws-mail-extra-plugins/claws-mail-extra-plugins.SlackBuild
blob: 89218dedc2959a414a2d515040ccd554e2432136 (plain)
#!/bin/sh

# SlackBuild Script to build the extra plugins for claws mail

# Copyright (c) 2007, Timothy Pollard
# Copyright (c) 2008, Erik Hanson
#
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without modification,
# are permitted provided that the following conditions are met:
#
# * Redistributions of source code must retain the above copyright notice,
#   this list of conditions and the following disclaimer.
# * Redistributions in binary form must reproduce the above copyright
#   notice, this list of conditions and the following disclaimer in the
#   documentation and/or other materials provided with the distribution.
#
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
# TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=claws-mail-extra-plugins
VERSION=3.6.1
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

# This is a *complete* list of available plugins
#PLUGIN_LIST="acpi_notifier archive att_remover attachwarner cachesaver \
#  fetchinfo-plugin gtkhtml2_viewer mailmbox newmail notification_plugin \
#  perl_plugin rssyl spam_report synce_plugin tnef_parse vcalendar"

# This is the list of plugins that the script will build by default
# Note that synce_plugin, archive and gtkhtml2_viewer are not included,
# as it requires library dependencies that are may not be available
# (see the README for more details) at SlackBuilds.org
PLUGIN_LIST="acpi_notifier archive att_remover attachwarner cachesaver \
  fetchinfo-plugin gtkhtml2_viewer mailmbox newmail notification_plugin \
  perl_plugin rssyl spam_report tnef_parse vcalendar"

if [ "$ARCH" = "i486" ]; then
    SLKCFLAGS="-O2 -march=i486 -mtune=i486"
elif [ "$ARCH" = "i686" ]; then
    SLKCFLAGS="-O2 -march=i686 -mtune=i686"
fi

set -eu

rm -rf $PKG $TMP/$PRGNAM-$VERSION
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp README $PKG/usr/doc/$PRGNAM-$VERSION

for plugin in $PLUGIN_LIST ; do
  cd ./$plugin-*
  CFLAGS="$SLKCFLAGS" \
    ./configure \
    --prefix=/usr \
    --sysconfdir=/etc \
    --localstatedir=/var/lib \
    --disable-static \
    --build=$ARCH-slackware-linux

  make
  make install DESTDIR=$PKG

  mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/$plugin
  for docfile in AUTHORS COPYING ChangeLog INSTALL NEWS README TODO ; do
    [ -e $docfile ] && cp -a $docfile $PKG/usr/doc/$PRGNAM-$VERSION/$plugin
  done
  cd -
done

cp $CWD/$PRGNAM.SlackBuild $PKG/usr/doc/$PRGNAM-$VERSION/
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

find $PKG | xargs file | egrep "ELF.*shared object" | cut -f 1 -d : \
          | xargs strip --strip-unneeded 2> /dev/null

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz