summaryrefslogtreecommitdiffstats
path: root/network/bitcoin/bitcoin.SlackBuild
blob: 43ad2bb9df4f0909c9ee9064e228684a28d584c9 (plain)
#!/bin/sh

# Slackware build script for bitcoin

# Copyright 2012 nomnombtc <nomnombtc@arcor.de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=bitcoin
VERSION=${VERSION:-0.8.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

# Detect miniupnpc
if [ -x /usr/bin/upnpc ]; then UPNP=1; else UPNP="-"; fi

# Detect qrencode
if [ -x /usr/bin/qrencode ]; then QRCODE=1; else QRCODE=0; fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION-linux
tar xvf $CWD/${PRGNAM}-$VERSION-linux.tar.gz
cd $PRGNAM-$VERSION-linux
chown -R root:root .
find . \
 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

cd src

# build bitcoin-qt
qmake \
  QMAKE_CFLAGS+="$SLKCFLAGS" \
  QMAKE_CXXFLAGS+="$SLKCFLAGS" \
  "USE_UPNP=$UPNP" \
  USE_QRCODE=$QRCODE \
  USE_SSL=1

make

# build bitcoind
cd src

  if [ "$UPNP" = "-" ]; then
    # disable UPNP
    sed -i 's/USE_UPNP:=0/USE_UPNP:=/g' makefile.unix
  fi

  # disable static linking, not supported by boost in slackware
  sed -i 's/Bstatic/Bdynamic/g' makefile.unix

  CFLAGS="$SLKCFLAGS" \
  CXXFLAGS="$SLKCFLAGS" \
  make -f makefile.unix \
    bitcoind \
    USE_SSL=1
cd -

mkdir -p $PKG/usr/{bin,man/man{1,5}}
mkdir -p $PKG/usr/share/{applications,kde4/services,pixmaps}

install -m 0755 bitcoin-qt $PKG/usr/bin/
install -m 0755 src/bitcoind $PKG/usr/bin/

install -m 0644 contrib/debian/manpages/bitcoin-qt.1 $PKG/usr/man/man1/
install -m 0644 contrib/debian/manpages/bitcoind.1 $PKG/usr/man/man1/
install -m 0644 contrib/debian/manpages/bitcoin.conf.5 $PKG/usr/man/man5/

install -m 0644 src/qt/res/icons/bitcoin.png $PKG/usr/share/pixmaps/
install -m 0644 $CWD/bitcoin-qt.desktop $PKG/usr/share/applications/
install -m 0644 $CWD/bitcoin.protocol $PKG/usr/share/kde4/services/

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a doc/README.md COPYING \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}