summaryrefslogtreecommitdiffstats
path: root/network/ajaxplorer-sync/ajaxplorer-sync.SlackBuild
blob: d2034272a813f88b3518699170b20e608c4bbd36 (plain)
#!/bin/sh

# SlackBuild script for "ajaxplorer-sync".

# Copyright 2013 Marcel Saegebarth <marc@mos6581.de>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions are
# met:
#
# * Redistributions of source code must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=ajaxplorer-sync
VERSION=0.8.3
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

SRCNAM=ajaxplorer_sync

case "$( uname -m )" in
  i?86) ARCH=i486 ;;
  arm*) ARCH=arm ;;
     *) ARCH=$( uname -m ) ;;
esac

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SRCARCH="x86"
elif [ "$ARCH" = "x86_64" ]; then
  SRCARCH=$ARCH
else
  echo "Only x86 & x86_64 is supported. Exit."
  exit 1
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION-SNAPSHOT-linux_$SRCARCH
unzip $CWD/$SRCNAM-$VERSION-SNAPSHOT-linux_$SRCARCH.zip
cd $SRCNAM-$VERSION-SNAPSHOT-linux_$SRCARCH
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

mkdir -p $PKG/opt/$PRGNAM $PKG/usr/bin $PKG/usr/doc/$PRGNAM-$VERSION \
$PKG/usr/share/applications $PKG/usr/share/pixmaps

cp -R . $PKG/opt/$PRGNAM
chmod 755 $PKG/opt/$PRGNAM/$PRGNAM-$VERSION-SNAPSHOT.jar

mkdir -p $PKG/usr/bin
cat <<- EOF > $PKG/usr/bin/$PRGNAM
#!/bin/sh
exec java -jar /opt/$PRGNAM/$PRGNAM-$VERSION-SNAPSHOT.jar
EOF
chmod 0755 $PKG/usr/bin/$PRGNAM

install -D -m 644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications
install -D -m 644 $CWD/${PRGNAM}_32x32.png $PKG/usr/share/pixmaps

cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}